Bug 463471 - Can't enable Monitoring Scout in 5.3
Can't enable Monitoring Scout in 5.3
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Preethi Thomas
:
Depends On:
Blocks: 463877
  Show dependency treegraph
 
Reported: 2008-09-23 12:18 EDT by Justin Sherrill
Modified: 2009-09-10 14:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:48:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2008-09-23 12:18:08 EDT
Basically on this page:
https://dhcp231-174.rdu.redhat.com/rhn/admin/config/MonitoringConfig.do?

When trying to enable the Monitoring Scout, i get an error.  Traceback to follow.

I know monitoring is basically busted currently, but this (for the most part) is the first 'symptom' you see as a user.
Comment 1 Justin Sherrill 2008-09-23 12:18:45 EDT
The following exception occurred while executing this request:
POST /rhn/admin/config/MonitoringConfig.do

Date:9/23/08 7:36:05 AM EDT
Headers:
  host: dhcp231-174.rdu.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071615 Fedora/3.0.1-1.fc9 Firefox/3.0.1
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,en;q=0.5
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://dhcp231-174.rdu.redhat.com/rhn/admin/config/MonitoringConfig.do?
  cookie: JSESSIONID=6210FEF4DACB4425F8B4F1756AEC33CD; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|488F892600000FA7-A3A095B0000007A[CE]; rh_omni_itc=bcm_edmsept_007; s_cc=true; s_sq=%5B%5BB%5D%5D; pxt-session-cookie=21x910473fc1354b2f79b212e755f342a0d
  content-type: application/x-www-form-urlencoded
  content-length: 282
  Max-Forwards: 10

Request:
Local Name = dhcp231-174.rdu.redhat.com
Server Name = dhcp231-174.rdu.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@284a284a[session=StandardSession[6210FEF4DACB4425F8B4F1756AEC33CD]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.error.message, javax.servlet.request.key_size, javax.servlet.request.ssl_session, __sitemesh__page, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, monitoringGeneralConfigForm, javax.servlet.error.exception, javax.servlet.error.servlet_name, org.apache.struts.action.MODULE, __sitemesh__filterapplied, javax.servlet.error.status_code, javax.servlet.error.request_uri, session, org.apache.struts.action.mapping.instance, requestedUri, 

Form Variables:
  RHN_DB_USERNAME: rhnsat
  XPROTO: https
  is_monitoring_scout: on
  MAIL_MX: localhost
  RHN_SAT_WEB_PORT: 443
  RHN_DB_TABLE_OWNER: rhnsat
  RHN_SAT_HOSTNAME: dually.rdu.redhat.com
  RHN_DB_PASSWD: rhnsat
  RHN_DB_NAME: rhnsat
  submitted: true
  RHN_ADMIN_EMAIL: jsherril@redhat.com
  MDOM: dually.rdu.redhat.com


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException: Not able to execute: [[/usr/bin/sudo, /etc/rc.d/np.d/step, MonitoringScout, install]] got back exit code: 1
	at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
	at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
	at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
	at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
	at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
	at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
	at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
	at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
	at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
	at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
	at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
	at java.lang.Thread.run(Thread.java:735)
Caused by: java.lang.RuntimeException: Not able to execute: [[/usr/bin/sudo, /etc/rc.d/np.d/step, MonitoringScout, install]] got back exit code: 1
	at com.redhat.rhn.manager.satellite.ConfigureSatelliteCommand.enableMonitoringScout(ConfigureSatelliteCommand.java:206)
	at com.redhat.rhn.manager.satellite.ConfigureSatelliteCommand.storeConfiguration(ConfigureSatelliteCommand.java:133)
	at com.redhat.rhn.frontend.action.satellite.MonitoringConfigAction.execute(MonitoringConfigAction.java:104)
	at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
	... 40 more
Comment 2 Miroslav Suchý 2009-01-30 05:44:33 EST
This page renders good for me now. Monitoring should be generally ok now.
Moving directly to ON_QA.
Comment 3 Preethi Thomas 2009-01-30 14:28:25 EST
verified.
Enabled Monitoring and Monitoring scout from webui and restarted satellite without any monitoring tracebacks.
Comment 4 Jan Pazdziora 2009-09-02 08:53:12 EDT
Stage validated. With Satellite-5.3.0-RHEL5-re20090820.1, there was not problem installing Satellite and enabling scout. Moving to RELEASE_PENDING.
Comment 5 Brandon Perkins 2009-09-10 14:48:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.