Bug 463486 - F10 Hard Drive ISO install behavior has changed
F10 Hard Drive ISO install behavior has changed
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Nalley
Paul W. Frields
:
: 465195 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-23 13:37 EDT by James Laska
Modified: 2013-09-02 02:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-23 13:12:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2008-09-23 13:37:24 EDT
The method to perform a hard drive ISO install has changed somewhat for Fedora 10. 

In addition to copying the ISO images to a free partition on your system, you must also provide a install.img file.  The installation program will not automatically use the images/install.img file located inside the ISO image.  

The procedure to continue using a network-less hard drive ISO install is described in the "repo=hd" section of https://fedoraproject.org/wiki/Anaconda/Options

Alternatively, users my choose to burn the images/boot.iso image and boot their system while specifying the command-line arguments: "repo=hd:<device>:<path_to_ISOs>
Comment 1 James Laska 2008-11-21 11:25:29 EST
What I just did was ...

1) You must have a spare partition (not logical volume) of sufficient size to hold my ISO images.  For my test, it's mount point was '/iso'
2) Copy the Fedora-10-ppc-DVD.iso into /iso/
3) Extract the "install.img" file from the DVD into '/iso/images/install.img'

$ mount -o loop /iso/dvd/Fedora-10-ppc-DVD.iso /mnt
$ mkdir /iso/dvd/images
$ cp -a /mnt/images/install.img /iso/dvd/images/
$ umount /mnt

4) Initiate install (boot from network, boot off of DVD, boot off of boot.iso)

5) Choose a language and keyboard

6) Select "Hard drive"

                       +----+ Installation Method +----+
                       |                               |
                       | What type of media contains   |
                       | the installation image?       |
                       |                               |
                       |         Local CD/DVD          |
                       |         Hard drive            |
                       |         NFS directory         |
                       |         URL                   |
                       |                               |
                       |    +----+        +------+     |
                       |    | OK |        | Back |     |
                       |    +----+        +------+     |
                       |                               |
                       |                               |
                       +-------------------------------+

7) Select the partition and directory containing the DVD iso

         +-------------------+ Select Partition +--------------------+
         |                                                           |
         | What partition and directory on that partition holds      |
         | the installation image for Fedora?  If you don't see      |
         | the disk drive you're using listed here, press F2 to      |
         | configure additional devices.                             |
         |                                                           |
         |                         /dev/sda1                         |
         |                         /dev/sda2                         |
         |                         /dev/sda3                         |
         |                         /dev/sdb1                         |
         |                                                           |
         |   Directory holding image: /dvd________________________   |
         |                                                           |
         |            +----+                     +------+            |
         |            | OK |                     | Back |            |
         |            +----+                     +------+            |
         |                                                           |
         |                                                           |
         +-----------------------------------------------------------+
Comment 2 David Nalley 2008-11-23 13:11:53 EST
*** Bug 465195 has been marked as a duplicate of this bug. ***
Comment 3 David Nalley 2008-11-23 13:12:58 EST
I made content changes including detailing how to extract install.img from isos. Pushed those up in commit 4787c12

Note You need to log in before you can comment on or make changes to this bug.