Bug 463552 - [LTC 6.0 FEAT] 201065:Modularization of qdio and thin interrupt layer
[LTC 6.0 FEAT] 201065:Modularization of qdio and thin interrupt layer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27
  Show dependency treegraph
 
Reported: 2008-09-23 17:01 EDT by IBM Bug Proxy
Modified: 2010-05-11 11:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 16:59:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 17:01:55 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 17:56 EDT
1. Feature Overview:
Feature Id:	[201065]
a. Name of Feature:	Modularization of qdio and thin interrupt layer
b. Feature Description
Provide a clean code separation for qdio in memory queues, thin interrupts and the initialization
method for specific interfaces. (prereq for new crypto features)

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27

3. Business Case
enable new System z crypto features

Benefits
simplify maintenance of kernel code

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-02 15:51:02 EDT
Did this actually make 2.6.27?
Comment 2 Gonzalo Muelas Serrano 2008-10-31 06:03:47 EDT
Correct, this feature was accepted upstream in kernel 2.6.27.
Comment 3 Bill Nottingham 2008-10-31 12:16:54 EDT
Since RHEL 6 will include at least 2.6.27, setting this to MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 Hans-Joachim Picht 2009-09-22 16:59:55 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE by Hans-Joachim Picht <hpicht@redhat.com>
Comment 5 IBM Bug Proxy 2010-05-11 11:02:18 EDT
------- Comment From mgrf@de.ibm.com 2010-05-11 10:52 EDT-------
This feature is verified on R6 betas
-> set to verified

Note You need to log in before you can comment on or make changes to this bug.