Bug 463559 - [LTC 6.0 FEAT] 201140:Standby memory add via SCLP
[LTC 6.0 FEAT] 201140:Standby memory add via SCLP
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27 515068
  Show dependency treegraph
 
Reported: 2008-09-23 17:21 EDT by IBM Bug Proxy
Modified: 2010-05-11 10:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 16:47:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 17:21:07 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:03 EDT
1. Feature Overview:
Feature Id:	[201140]
a. Name of Feature:	Standby memory add via SCLP
b. Feature Description
Add support to define additional memory via the service description processor interface.  Make use
of the 'Assign Storage' and 'Attach Storage Element' SCLP commands to attach memory  to the image.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Both
Affects Core Kernel: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27

3. Business Case
allow customers to dynamically reconfigure images and allow on-demand adaptations to their
increasing workload.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-02 15:54:11 EDT
Did this make 2.6.27?
Comment 2 Gonzalo Muelas Serrano 2008-10-31 07:03:07 EDT
Correct, this is upstream with kernel 2.6.27
Comment 3 Bill Nottingham 2008-10-31 12:17:02 EDT
Since RHEL 6 will include at least 2.6.27, setting this to MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 4 Hans-Joachim Picht 2009-09-22 16:47:13 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE by by Hans-Joachim Picht <hpicht@redhat.com>
Comment 5 IBM Bug Proxy 2010-05-11 10:53:09 EDT
------- Comment From mgrf@de.ibm.com 2010-05-11 10:44 EDT-------
This feature is verified on R6 betas
-> set o to verified

Note You need to log in before you can comment on or make changes to this bug.