Bug 463562 - [LTC 6.0 FEAT] 201100:POWER6 SPURR support
[LTC 6.0 FEAT] 201100:POWER6 SPURR support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
ppc64 All
high Severity high
: alpha
: 6.0
Assigned To: Kevin W Monroe
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 525727
  Show dependency treegraph
 
Reported: 2008-09-23 17:21 EDT by IBM Bug Proxy
Modified: 2010-05-07 00:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-23 18:02:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 17:21:32 EDT
=Comment: #1=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-17 15:59 EDT
1. Feature Overview:
Feature Id:	[201100]
a. Name of Feature:	POWER6 SPURR support
b. Feature Description
POWER6 manages power and thermal issues by varying the processor clock frequency
and/or throttling instruction dispatch. In order to measure the consumption of
effective CPU resources more accurately under these conditions, POWER6 added a
Scaled Processor Utilization of Resources Register (SPURR). This feature adds
code to read the SPURR at appropriate times in order to be able to report scaled
CPU time usage to programs that need it such as EWLM.

2. Feature Details:
Sponsor:	PPC
Architectures:
ppc64

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.24

3. Business Case
Without this feature EWLM will not be able to manage computing resources
accurately when the  CPU frequency is varied by the POWER6 thermal management
system.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael Hohnbaum, hbaum@us.ibm.com, 503-578-5486

Technical contact(s):
Paul Mackerras, pmac@au1.ibm.com

IBM Manager:
Pat Gaughen, gaughen@us.ibm.com
Comment 1 Bill Nottingham 2008-10-02 15:56:13 EDT
RHEL 6 will include a kernel later than 2.6.24, so this should not be a problem.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 2 IBM Bug Proxy 2009-03-02 14:51:29 EST
This is in 2.6.20
it is in 2 main parts
sha1 id: spurr sysfs f050982a9b7c4edc414f0d5543c3cb24504223c6
sha1 id: spurr taskstats 4603ac180a824197c2262747948d0179eb076e9c
Comment 3 Kevin W Monroe 2009-09-23 18:02:53 EDT
Closing - included in Red Hat Enterprise Linux 6.
Comment 4 IBM Bug Proxy 2010-05-07 00:30:42 EDT
------- Comment From paulus@au1.ibm.com 2010-05-07 00:21 EDT-------
Turns out the reason I was seeing multiples of 1000 is that the kernel code does

stats->ac_utimescaled =
cputime_to_msecs(tsk->utimescaled) * USEC_PER_MSEC;
stats->ac_stimescaled =
cputime_to_msecs(tsk->stimescaled) * USEC_PER_MSEC;

So it's all working as expected.

Note You need to log in before you can comment on or make changes to this bug.