Bug 463601 - [LTC 6.0 FEAT] 201171:FCP Automatic Port Discovery
[LTC 6.0 FEAT] 201171:FCP Automatic Port Discovery
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On: 707020
Blocks: 356741 RHEL6Kernel2.6.27 579599
  Show dependency treegraph
 
Reported: 2008-09-23 23:00 EDT by IBM Bug Proxy
Modified: 2011-08-24 15:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 579599 (view as bug list)
Environment:
Last Closed: 2009-09-14 09:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 23:00:37 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:05 EDT
1. Feature Overview:
Feature Id:	[201171]
a. Name of Feature:	FCP Automatic Port Discovery
b. Feature Description
This item would enable zFCP to scan the connected fibre channel SAN and to activate all available
and accessible target ports.

Additional Comments:	This feature has a related installer part, feature 201689: Installer - FCP
automatic port discovery

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Driver - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27

3. Business Case
Increased Ease-of-Use of the FCP Attachment

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:18:07 EDT
Did this make 2.6.27? What (if anything) is the kernel/userspace interface like?
Comment 2 Gonzalo Muelas Serrano 2008-10-31 07:21:33 EDT
Correct, this is upstream in kernel 2.6.27.

After setting a FCP adapter devno. manually online, the zfcp driver will automatically scan and add to the sysfs the reachable/founded WWPNs from the storage server.

Please remember that the documentation in the Installation Guide should be updated.

Here is an example screenshot with kernel 2.6.27:
*** Just after reboot a system with 1 FCP adapter/devno attached ****
[root@h0515007 ~]# ls /sys/bus/ccw/drivers/zfcp/
0.0.1707  bind  uevent  unbind
[root@h0515007 ~]# ls /sys/bus/ccw/drivers/zfcp/0.0.1707/
availability  cutype   hardware_version  online     port_remove  uevent
bus           devtype  in_recovery       peer_d_id  port_rescan
card_version  driver   lic_version       peer_wwnn  status
cmb_enable    failed   modalias          peer_wwpn  subsystem

*** When setting the devno online, WWPN discovery happens automaticaly in zfcp
kernel driver ***
[root@h0515007 ~]# echo 1 > /sys/bus/ccw/drivers/zfcp/0.0.1707/online 
[root@h0515007 ~]# ls /sys/bus/ccw/drivers/zfcp/0.0.1707/
0x500308c141699001  0x5005076303098335  0x500507630e8202aa  modalias
0x500308c141699004  0x50050763030b0104  availability        online
0x500507630040710b  0x50050763030bc562  bus                 peer_d_id
0x500507630040727b  0x5005076303100104  card_version        peer_wwnn
0x5005076300c20b8e  0x5005076303108104  cmb_enable          peer_wwpn
0x5005076300c7b130  0x500507630310c562  cutype              port_remove
0x5005076300cbb130  0x500507630313c562  devtype             port_rescan
0x5005076300cc0b8e  0x5005076303148335  driver              status
0x5005076303000104  0x5005076303198335  failed              subsystem
0x5005076303008104  0x50050763031b0104  hardware_version    uevent
0x500507630300c562  0x500507630e0002aa  host0
0x500507630303c562  0x500507630e0202aa  in_recovery
0x5005076303048335  0x500507630e8002aa  lic_version
Comment 3 Bill Nottingham 2008-10-31 12:12:23 EDT
Why is manual onlining needed? (This correlates to a question in the other bug) - what's the downside of having the driver do it automatically?
Comment 4 Gonzalo Muelas Serrano 2008-11-03 10:35:19 EST
Because if the System z device drivers would automatically set online all the devices sensed (some customers have 4K devices), then precious resources in the machine would be wasted.
Since System z machines are expensive enough, we don't want to waste customers resources. Activating only the ones that the customer will explicit use, to be decided during the installation and init/cfg files.
Comment 6 Bill Nottingham 2008-11-03 12:23:22 EST
Why can't the visibility of devices be set at the zVM level, much like FC/iscsi visibility being set at the SAN level?
Comment 7 IBM Bug Proxy 2009-03-02 08:02:20 EST
via upstream kernel, no code to attach to feature BZ
Comment 8 IBM Bug Proxy 2009-03-03 03:30:42 EST
This feature has a required co-feature request in installer to be complete
That is:
48104 ??-?? RHBZ 463186 [LTC 6.0 FEAT] 201689:Installer - FCP automatic port discovery
Comment 9 Peter Martuccelli 2009-09-14 09:59:45 EDT
Kernel portion is upstream, requires release note and installer support.
Comment 10 Hans-Joachim Picht 2009-09-22 18:03:58 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE
Comment 13 IBM Bug Proxy 2010-04-29 06:11:01 EDT
------- Comment From mgrf@de.ibm.com 2010-04-29 06:03 EDT-------
This feature is successful verified on beta1
Set feature to "verified"  - Thx-

Note You need to log in before you can comment on or make changes to this bug.