Bug 463608 - [LTC 6.0 FEAT] 201175:Support for Eclipse IDE Plattform
[LTC 6.0 FEAT] 201175:Support for Eclipse IDE Plattform
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: eclipse (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.1
Assigned To: Andrew Overholt
eclipse-bugs
: FutureFeature, Reopened
Depends On:
Blocks: 538808 580566
  Show dependency treegraph
 
Reported: 2008-09-23 23:11 EDT by IBM Bug Proxy
Modified: 2010-04-08 13:12 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-21 17:22:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-23 23:11:10 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:05 EDT
1. Feature Overview:
Feature Id:	[201175]
a. Name of Feature:	Support for Eclipse IDE Platform
b. Feature Description
Eclipse is an open source software development project dedicated to providing a robust,
full-featured, commercial-quality, industry platform for the development of highly integrated tools.
It is composed of three projects, the Eclipse Project, the Eclipse Tools Project and the Eclipse
Technology Project, each of which is overseen by a Project Management Committee (PMC) and governed
by its Project Charter. Each project is composed of its own subprojects and is licensed under the
CPL version 1.0. Eclipse has architecture dependent part which must be adapted to Linux on zSeries.
At least Version 3.3 is needed.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	zSeries
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	no
g. Component Version Target:	eclipse 3.3 or higher at http://download.eclipse.org/eclipse/downloads/

3. Business Case
Eclipse Rich Client Platform support for zSeries was requested by the WebSphere team. Eclipse is
needed for WebSphere's graphical installation wizard.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-02 16:25:05 EDT
eclipse is currently at 3.4.0 in Fedora.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 3 RHEL Product and Program Management 2009-09-17 15:59:18 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.
Comment 4 Gonzalo Muelas Serrano 2009-09-24 04:20:22 EDT
Hello Red Hat,

regarding the reject from Dev. Mgmt. for the Feat. Req. Eclipse for System z:
- Red Hat had till now (in RHEL 5.4 is version 3.2.1-19) provided Eclipse only on Intel and POWER because till version 3.2, System z was not supported (see: http://archive.eclipse.org/eclipse/downloads/drops/R-3.2.1-200609210945/index.php).
- Since version 3.3 (see: http://archive.eclipse.org/eclipse/downloads/drops/R-3.3-200706251500/index.php) is System z also supported and certified, and that is why we requested for RHEL 6 on System z, since we assumed that you would continue to ship Eclipse for all the platforms. Also the latest version, 3.5, is supported in System z, see http://download.eclipse.org/eclipse/downloads/drops/R-3.5-200906111540/index.php

* Is Eclipse going to be removed from all plattforms on RHEL 6?
* Or is Red Hat only rejecting this req. to provide it also for System z and will continue providing it on Intel and POWER?
* In any case which is the concrete reason for the reject?

Thank you!
Gonzalo Muelas Serrano.
Comment 5 Gonzalo Muelas Serrano 2009-09-24 04:23:45 EDT
Reopening to get an answer...
Comment 9 Shawn Wells 2009-09-28 21:13:42 EDT
From a Red Hat side, this has three primary business drivers;

1)  Eclipse for System z support is needed in order to formally certify JBoss Developer Studio on System z.  Irrespective of IBMs needs/desires, we have one of our own internal products hinging on the need for Eclipse on System z support.  

2)  Engagement in the Lotus on Linux campaign with IBM.  IBM has launched a world-wide Lotus on Linux campaign with System z being the preferred platform for large deployments.  As most Lotus developers use Eclipse as their IDE for java work,  support becomes critical to enter this market.  

3)  As mentioned by Gonzalo in comment #4, Eclipse for System z has formerly NOT been upstream, and thus not included in RHEL in the past.  There is now upstream acceptance of the s390x port, removing this issue.  IBM has dedicated a dedicated headcount for maintaining the Eclipse s390 port (named Uttaran Dutta, a eclipse.org committer and formal maintainer of the s390x port). One big theme from Red Hat is that "Linux is Linux, regardless of platform."  The inclusion of Eclipse for System z will further enable this statement to become true, effecting our overall brand perception in the market of Red Hat being a leader in the Linux space.  To enable this we are simply pulling in upstream bits that are already present on alternate architectures, which should be trivial.
Comment 11 John Jarvis 2009-12-16 22:47:43 EST
Rejected for RHEL 6.0, closing as DEFERRED and putting it on the 6.1 tracker for consideration for that release.
Comment 12 Gonzalo Muelas Serrano 2009-12-21 08:46:08 EST
Hello John,

- why is it rejected for RHEL 6?
- Is it also rejected for System x and POWER?

Thank you!
Gonzalo.
Comment 13 John Jarvis 2009-12-21 12:09:41 EST
Eclipse will be fully supported on i386 and x86_64 architectures at the time of RHEL 6.0 GA. The plan is to support Eclipse on PPC post RHEL 6.0. This is due to the lack of maturity of the JIT compiler (Shark) on this platform. Shark has been built on PPC but will not be mature at the time of RHEL 6.0 GA. There are no immediate plans to support Eclipse on System z as it is unclear as to what use-case exists to support it on this platform.
Comment 14 Gonzalo Muelas Serrano 2009-12-21 12:17:16 EST
In comment #10 are two ( 1) and 2) ) very interesting use cases described. How many more do you need?
Comment 15 John Jarvis 2009-12-21 17:22:27 EST
No, System z needs to provide their own use-cases and business justification. 

> 1)  Eclipse for System z support is needed in order to formally certify JBoss
> Developer Studio on System z.

JBDS doesn't use RPMs and is completely independent of our Eclipse RPMs in
RHEL.
Comment 16 IBM Bug Proxy 2010-01-13 09:00:40 EST
------- Comment From gmuelas@de.ibm.com 2010-01-13 08:50 EDT-------

the same use-cases that i386 and x86_64 architectures have and that will be supported at RHEL 6 GA should apply for System z.

Why have you decided to not provide it for RHEL 6 GA System z customers?

Note You need to log in before you can comment on or make changes to this bug.