Bug 463619 - [LTC 6.0 FEAT] 201223:DHCPv6 updates
[LTC 6.0 FEAT] 201223:DHCPv6 updates
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Jiri Popelka
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-23 23:50 EDT by IBM Bug Proxy
Modified: 2009-09-23 18:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 20:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TFD for the information refresh time option (2.11 KB, text/plain)
2008-09-29 06:41 EDT, IBM Bug Proxy
no flags Details
TFD for the information refresh time option (updated) (2.11 KB, text/plain)
2008-10-23 22:51 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-09-23 23:50:39 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:07 EDT
1. Feature Overview:
Feature Id:	[201223]
a. Name of Feature:	DHCPv6 updates
b. Feature Description
Update DHCPv6 implemenation(Client, Server & Relay Agent) to support the missing features and pass
all the testcases in the DHCPv6 testsuite for IPv6 Ready Logo Phase-2 that targets the following
RFCs      
*  RFC3315 - Dynamic Host Configuration Protocol for IPv6(DHCPv6)      
* RFC3646 - DNS Configuration options for Dynamic Host Configuration Protocol for IPv6(DHCPv6)      
* RFC3736 - Stateless Dynamic Host Configuration Protocol(DHCP) Service for IPv6

Additional Comments:	This features is to support the information refresh time option.  RFC 4242. 
this is not including in RHEL5.3

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64
s390 native
s390x

Arch Specificity: Purely Common Code
Delivery Mechanism: 
Category:	Networking
Request Type:	Package - Update Version
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	dhcpv6-1.X available at http://dcantrel.fedorapeople.org/dhcpv6/  
Expected upstream May 2008.

3. Business Case
Enable full compliance with IPv6 Ready Logo Phase-2 and IPv6 DoD product profile requirements.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mike Wortman, wortman@us.ibm.com, 512-838-8582

Technical contact(s):
Sridhar Samudrala, samudrala@us.ibm.com
Mitsuru Chinen, chinen@jp.ibm.com

IBM Manager:
Larry Kessler, lkessler@us.ibm.com
=Comment: #1=================================================
Mitsuru Chinen <chinen@jp.ibm.com> - 2008-09-16 20:58 EDT
Regarding the upstream, patches to support RFC4242 (Information Refresh
Time Option) are integrated into dhcpv6-1.0.22.
Comment 1 IBM Bug Proxy 2008-09-29 06:41:00 EDT
Created attachment 317947 [details]
TFD for the information refresh time option
Comment 2 IBM Bug Proxy 2008-10-23 22:51:13 EDT
Created attachment 321368 [details]
TFD for the information refresh time option (updated) 

Excuse me, there are some typos in TFD.
I upload correct one.
Comment 4 David Cantrell 2009-09-21 20:28:27 EDT
The dhcpv6 package has been obsoleted by the dhcp package.
Comment 5 Denise Dumas 2009-09-22 12:21:49 EDT
Since the dhcp package now includes ipv6 functionality on par (at least) with dhcpv6, and since we have to ship dhcp anyway, we're going to remove the dhcpv6 package from RHEL6.
Comment 6 Denise Dumas 2009-09-22 14:15:46 EDT
Because we need to remove the dhcpv6 component from bugzilla, I am moving this BZ  to component dhcp.
Comment 7 IBM Bug Proxy 2009-09-23 18:00:57 EDT
------- Comment From sglass@us.ibm.com 2009-09-23 17:57 EDT-------
Quiting feature to match Red Hat.

Note You need to log in before you can comment on or make changes to this bug.