Bug 463631 - rpmlint fails to catch some errors/warnings
rpmlint fails to catch some errors/warnings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 00:11 EDT by Randall "Randy" Berry
Modified: 2008-09-25 14:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 14:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randall "Randy" Berry 2008-09-24 00:11:07 EDT
Description of problem:
rpmlint fails to detect some errors when checking spec files as 'rpmlint packagename.spec' as compared to using 'rpmlint packagename.src.rpm'

Version-Release number of selected component (if applicable):
rpmlint-0.84-2.fc9.noarch

How reproducible:
Always


Steps to Reproduce:
1.Check files using 'rpmlint packagename.spec' and some errors are overlooked returning 0 errors 0 warnings.
2.Checking same spec file within an SRPM using 'rpmlint packagename.src.rpm' and overlooked errors appear.
  
Actual results:
Seems to miss certain missing tags such as URL: space/tab mixing missing version on changelog.

Expected results:
Both methods of checking spec files should return same results.

Additional info:
Comment 1 Ville Skyttä 2008-09-25 14:32:23 EDT
Many checks rpmlint does are run against rpm packages only, not on spec files.  The reason is simply that it's much more reliable to do that way (think macro expansion etc) at least until there's a usable specfile API available from rpm for rpmlint to use.  In that sense, this is not a bug.  If you disagree, feel free to open a RFE at http://rpmlint.zarb.org/

There was however one related bug in 0.84 which caused some UTF-8 checks which should have been enabled to be skipped in specfile-only mode, this has been fixed in upstream svn.

By the way, rpmlint-0.84-2.fc9 does check space/tab mixing on specfiles for me.

Note You need to log in before you can comment on or make changes to this bug.