Bug 463688 - [LTC 6.0 FEAT] 201591:FCP - Performance Data collection & analysis (userspace)
[LTC 6.0 FEAT] 201591:FCP - Performance Data collection & analysis (userspace)
Status: CLOSED DUPLICATE of bug 462976
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
s390x All
high Severity high
: alpha
: ---
Assigned To: Dan Horák
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
Reported: 2008-09-24 02:20 EDT by IBM Bug Proxy
Modified: 2009-09-17 14:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-09-17 14:10:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 02:20:56 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:19 EDT
1. Feature Overview:
Feature Id:	[201591]
a. Name of Feature:	FCP - Performance Data collection & analysis (userspace)
b. Feature Description
The item comprises: a) facilities which provide performance relevant data (see below) at any time b)
facilities which collect the data provided by a), then associate it with a time stamp and and store
it for future processing - these facilities are configurable in regard of the type and amount of
data collected for the purpose of reducing the amount of temporarily stored data. - when data is
taken as samples, the sampling interval is configurable - collected data can be filtered by e.g
masks for valid stack components (see below) before data is stored for further processing c)
facilities which present the data stored by b) in a human readable way. d) Data presented shall
contain enough information to make FCP performance data comparable with current capabilities of
FICON data collections. Data collected comprises: a) Performance relevant data about stack
components as Linux devices, SCSI LUNs and HBA and storage controller information b) Per stack
component: current values of relevant measurements as throughput, utilization and other applicable
measurements c) Statistical aggregations (min, max average, histogram) of data associated with I/O
requests as size, latency per component and in total.

Additional Comments:	This feature is the userspace part to feature 201590 FCP - Performance Data
collection & analysis (kernel), and feature 201729 FCP - Performance Data collection & analysis

2. Feature Details:
Sponsor:	zSeries

Arch Specificity: Purely Arch Specific Code
Delivery Mechanism: Direct from community
Category:	zSeries
Request Type:	Package - Feature from Upstream
d. Upstream Acceptance:	Accepted
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	s390tools 1.7.x

3. Business Case
This item will make possible to have a better understanding of the SCSI activities and performance
of the customer system, being able afterward to better solve FCP issues regarding customer's SCSI

4. Primary contact at Red Hat: 
John Jarvis

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):

Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-03-03 14:21:26 EST
The code for this feature get delivered in s390-tools with feature request:
48095  - RHBZ 462976  [LTC 6.0 FEAT] 201674: Pick up latest version of

This feature has two required co-feature requests to be complete,
that are
48075 ??-?? RHBZ 463689 [LTC 6.0 FEAT] 201590:FCP - Performance Data collection (kernel)
48116 ??-?? RHBZ 464179 [LTC 6.0 FEAT] 201729:FCP - Performance data collection (blktrace)
Comment 2 John Jarvis 2009-09-17 14:10:32 EDT
duping to package rebase BZ.

*** This bug has been marked as a duplicate of bug 462976 ***

Note You need to log in before you can comment on or make changes to this bug.