Bug 46370 - traceback during kickstart installs
traceback during kickstart installs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-27 23:50 EDT by Ben Levenson
Modified: 2007-04-18 12:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 11:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2001-06-27 23:50:56 EDT
build qa0627.3

Description of Problem:
--Was not able to complete any kickstart installs.

--I used the anaconda-ks.cfg file that was generated 
   during an install on the same system that I was 
   attempting the kickstart install on.

--The only modification to anaconda-ks.cfg was for the hostname
   and the install source:
   nfs --server porkchop --dir /mnt/redhat/test/qa0627.3/i386
   -or-
   url --url ftp://porkchop.redhat.com/mnt/test/qa0627.3/i386

--Tried w/ NFS, FTP, and HTTP install sources.

NFS:
Traceback occurs just after running anaconda:
File /usr/bin/anaconda, line 528, in ?
  instClass, setInstallData(id)
File /usr/lib/anaconda/kickstart.py, line 708, in setInstallData
  self.read kickstart(id, self.file)
File /usr/lib/anaconda/kickstart.py, line 475, in readKickstart
  args = isys_parseArgv(n)
File /usr/lib/anaconda/kickstart.py, line 277, in parseArgv
  return _isys.poptParseArgv(str)
ValueError = bad string for parsing

FTP/HTTP:
File /usr/bin/anaconda, line 155, in ?
  from kickstart import kickstart
ImportError: No module named kickstart


How Reproducible:
100%
Comment 1 Michael Fulbright 2001-06-28 16:05:33 EDT
Please retry with any tree after qa0628.0.
Comment 2 Ben Levenson 2001-06-29 14:17:21 EDT
TUI and GUI kickstart installs completed successfully w/
the 0629.0 tree.

"reboot" flag did not reboot computer.
Comment 3 Michael Fulbright 2001-07-02 11:35:05 EDT
The reboot issue is a known one.
Comment 4 Brock Organ 2001-07-12 16:00:27 EDT
a similar (but not identical) traceback is occuring in qa0711.4 ... this is a 
sporadic problem as kickstart worked in qa0709.3 test tree ... reopening ...
Comment 5 Glen Foster 2001-07-13 15:44:12 EDT
This defect considered MUST-FIX for Fairfax gold-release.
Comment 6 Jeremy Katz 2001-07-16 11:30:05 EDT
This is because kickstart.py wasn't being pulled into the ftp/http images.  msw
committed a fix for this on Friday
Comment 7 Pekka Savola 2001-07-21 13:00:31 EDT
I noticed the same problem with FTP installs on beta2.  Using updates disk fixed
it.

Note You need to log in before you can comment on or make changes to this bug.