Bug 463707 - [LTC 6.0 FEAT] 201735:TTY terminal server over IUCV (userspace)
[LTC 6.0 FEAT] 201735:TTY terminal server over IUCV (userspace)
Status: CLOSED DUPLICATE of bug 462976
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: s390utils (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Dan Horák
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-24 03:11 EDT by IBM Bug Proxy
Modified: 2009-09-17 14:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 14:09:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 03:11:05 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:23 EDT
1. Feature Overview:
Feature Id:	[201735]
a. Name of Feature:	TTY terminal server over IUCV (userspace)
b. Feature Description
Implement client & server for a TTY terminal server under z/VM using IUCV as communication vehicle.
   This line item implements the terminal server running on a dedicated z/VM guest.  The terminal
server is a user space program that accepts connections via the normal network and uses the AF_IUCV
socket API to provide a console session to the Linux guests of the z/VM system that are enabled for
the IUCV console.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Delivery Mechanism: Direct from community
Category:	RAS
Request Type:	Package - Feature from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	s390tools

3. Business Case
Customer requirement to solve restriction to access to the Linux console for many Linux
administrators concurrently and they find the z/VM 3270 interface inadequate for the 200+ Linux
admins due to the inability to use common programs such as vi from this interface. The customer has
a requirement that the Linux system that needs to have its console accessed, will have its TCPIP
stack shutdown, so the solution can not involve an IP connection to that system IP stack.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 Bill Nottingham 2008-10-03 11:02:54 EDT
Please let us know when this is more fleshed out, so we can do any necessary setup and integration required. Is this considered a 'secure' local tty (like tty1-6 on a x86 box, or a serial console), or an insecure one (like telnet sessions)?
Comment 2 IBM Bug Proxy 2009-03-03 13:30:33 EST
This feature has a required co-feature request to be complete
That is:
48121 ??-?? RHBZ 463708 [LTC 6.0 FEAT] 201734:TTY terminal server over IUCV (kernel)
Comment 3 IBM Bug Proxy 2009-03-04 04:10:50 EST
The code for this feature get delivered in s390-tools with feature request:
48095  - RHBZ 462976  [LTC 6.0 FEAT] 201674: Pick up latest version of
s390-tools
Comment 4 John Jarvis 2009-09-17 14:09:34 EDT
duping to package rebase BZ.

*** This bug has been marked as a duplicate of bug 462976 ***

Note You need to log in before you can comment on or make changes to this bug.