Bug 463708 - [LTC 6.0 FEAT] 201734:TTY terminal server over IUCV (kernel)
[LTC 6.0 FEAT] 201734:TTY terminal server over IUCV (kernel)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: ---
Assigned To: Hans-Joachim Picht
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 465491
  Show dependency treegraph
 
Reported: 2008-09-24 03:11 EDT by IBM Bug Proxy
Modified: 2010-08-19 08:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-14 10:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 03:11:12 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-16 18:23 EDT
1. Feature Overview:
Feature Id:	[201734]
a. Name of Feature:	TTY terminal server over IUCV (kernel)
b. Feature Description
Implement client & server for a TTY terminal server under z/VM using IUCV as communication vehicle.
   This line item corresponds to the terminal client running on the numerous guests.  The terminal
client is a Linux tty / console driver with a fixed device node.

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.29

3. Business Case
Customer requirement to solve restriction to access to the Linux console for many Linux
administrators concurrently   and they find the z/VM 3270 interface inadequate for the 200+ Linux
admins due to the inability to use common   programs such as vi from this interface.    The customer
has a requirement that the Linux system that needs to have its console accessed, will have its TCPIP
stack shutdown, so the solution can not involve an IP connection to that system IP stack.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-03-03 11:30:48 EST
This feature has a required co-feature request in s390-tools to be complete
That is:
48122 ??-?? RHBZ 463707 [LTC 6.0 FEAT] 201735:TTY terminal server over IUCV (userspace)
The code for all s390-tools related feature requests get delivered with
48095 ??- RHBZ 462976  [LTC 6.0 FEAT] 201674:Pick up latest version of s390-tools
Comment 2 IBM Bug Proxy 2009-03-03 11:41:12 EST
The code for this feature is upstream accepted with kernel 2.6.29.
nothing to attach here
Comment 3 IBM Bug Proxy 2010-08-19 08:21:53 EDT
------- Comment From mgrf@de.ibm.com 2010-08-19 08:18 EDT-------
This feature is verified on R6 snapshots
Set feature to "verified"  Thx

Note You need to log in before you can comment on or make changes to this bug.