Bug 463717 - radeon9800: X fails to start wihtout nomodeset
radeon9800: X fails to start wihtout nomodeset
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 04:03 EDT by Hans de Goede
Modified: 2008-10-22 16:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-22 16:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.log from successfull X start with nomodeset (76.27 KB, text/plain)
2008-09-24 04:03 EDT, Hans de Goede
no flags Details

  None (edit)
Description Hans de Goede 2008-09-24 04:03:38 EDT
Created attachment 317568 [details]
xorg.log from successfull X start with nomodeset

Description of problem:
x86_64 system with agp rv350 / radeon 9800pro card, running i386 install of rawhide (post F-10 beta freeze) on a 1280x1024 vga attached no brand lcd monitor.
Booting into runlevel 3 with modesetting works fine (so the mode gets set and the output lights up and the console on fb stuff works, but when I start X the system freezes (haven't tried ssh access yet, but no keyb/mouse) with a screen full of "crap"

I've attached my Xorg.log from a successfull start of Xorg when starting with the nomodeset kernel option.

Let me know what else you need, I can even hook up a serial console if you want me to, I'll do anything to get this darn bug fixed :)
Comment 1 Christopher D. Stover 2008-10-22 16:24:56 EDT

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.