Bug 463765 - kvm's keymap is broken
kvm's keymap is broken
Status: CLOSED DUPLICATE of bug 478976
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 12:10 EDT by Matthias Clasen
Modified: 2009-02-13 00:12 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 00:12:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2008-09-24 12:10:08 EDT
When running the F10beta live cd in qemu-kvm, I see the same up/printscreen confusion that was plaguing our earlier attempt to switch to evdev in F8.
X is using the evdev driver, and the xkb information on the root window seems to be correct: base, evdev, us

danpb said: i didn't realize it'd affect sdl too
Comment 1 Daniel Berrange 2008-09-24 13:04:39 EDT
Can you give me the output of

setxkbmap -print

on your host X server


And if you have got as far as running a guest with X inside it, can you also run the same command in the guest X server.
Comment 2 Matthias Clasen 2008-09-25 01:08:12 EDT
This is the host X server

[mclasen@localhost po]$ setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+inet(evdev)+de(deadgraveacute):2+no:3+level3(ralt_switch_for_alts_toggle):1+level3(ralt_switch_for_alts_toggle):2+level3(ralt_switch_for_alts_toggle):3+group(alts_toggle)"	};
	xkb_geometry  { include "pc(pc104)"	};
};


and this is inside the vm:

xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+inet(evdev)"     };
	xkb_geometry  { include "pc(pc104)"	};
};
Comment 3 Peter Hutterer 2008-09-25 04:43:17 EDT
FWIW, I just created + burned a livecd and when I boot from CD, I don't see this issue.

This seems to be a dupe of Bug 435634 which was only closed by switching back to kbd.
Comment 4 Daniel Berrange 2008-09-25 05:53:46 EDT
Cross-reference to similar problem Ubuntu KVM developer recently foudn

https://lists.ubuntu.com/archives/ubuntu-devel/2008-August/026076.html
Comment 5 Bug Zapper 2008-11-25 22:12:35 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Warren Togami 2008-12-05 14:22:58 EST
kvm is sending bad key codes to text VT running in kvm.  This is not limited to X.
Comment 7 Daniel Rowe 2009-01-20 07:02:24 EST
I am seeing this bug(?) as well and have to specify the keymap on the qemu-kvm command line with the -K flag.

This didn't happen in < F10.
Comment 8 Jens Petersen 2009-02-09 22:04:03 EST
This happens on rawhide too (rawhide on rawhide and F10 on rawhide).

This can be easily reproduced with:

$ sudo qemu-kvm -m 512 -cdrom F11-Alpha-i686-Live.iso

and then pressing Up after autologin if liveuser, etc.  Same for F9, F10 or newer rawhide spins.

(I am using a standard US keyboard and layout.)
Comment 9 Mark McLoughlin 2009-02-10 03:38:36 EST
Is this the same issue as bug #478976 

Note, bug #478976 has a work-in-progress patch.
Comment 10 Mace Moneta 2009-02-10 10:39:57 EST
Yes, it appears to be the same issue.  I've been working around the problem with the option '-k en-us' to qemu-kvm.
Comment 11 Jens Petersen 2009-02-13 00:12:05 EST

*** This bug has been marked as a duplicate of bug 478976 ***

Note You need to log in before you can comment on or make changes to this bug.