Bug 463788 - [LTC 6.0 FEAT] 201037:Ext4
[LTC 6.0 FEAT] 201037:Ext4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
medium Severity medium
: alpha
: 6.0
Assigned To: Eric Sandeen
Red Hat Kernel QE team
: FutureFeature
Depends On:
Blocks: 534150 356741 RHEL6Kernel2.6.27 519825 531073 554537 554559 555224 575260
  Show dependency treegraph
 
Reported: 2008-09-24 14:20 EDT by IBM Bug Proxy
Modified: 2010-11-11 09:41 EST (History)
6 users (show)

See Also:
Fixed In Version: kernel-2.6.31-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-11 09:41:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 14:20:40 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:50 EDT
1. Feature Overview:
Feature Id:	[201037]
a. Name of Feature:	Ext4
b. Feature Description
Ext4 was created to incorporate scalability and performance enhancements in support of large
filesystems, while maintaining reliability and stability. Ext4 will be suitable for a larger variety
of workloads, and is expected to replace ext3 as 'the' Linux filesystem. Features ultimately will
include filesystem sizes up to 1EB and file sizes up to 2TB, directory size scaling, preallocation,
and fast fsck, but the emphasis initially is on insuring the filesystem is an option in distro
kernel and preallocation feature is enabled.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Purely Common Code
Affects Core Kernel: Yes
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.27

3. Business Case
These filesystem enhancements are critical to Linux' ability to scale with enterprise workloads and
facilitate competition against other OS's in these markets.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Mingming Cao, mcao@us.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 IBM Bug Proxy 2009-02-27 14:50:28 EST
status of getting ext4 acceptance in upstream and stability:

since 2.6.19 upstream has included ext4 as a development fs.
2.6.28 kernel marks ext4 filesystem stable and ready for distro to pick up. Many bugs are fixed in 2.6.29 kernel.  By the time kernel feature cut off date , it should be in a good shape to be included in RHEL6.

Mingming
Comment 2 Bill Nottingham 2009-02-27 16:02:23 EST
Setting as MODIFIED.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 3 Ric Wheeler 2009-02-27 18:09:11 EST
Note that ext4 is also out in tech preview in RHEL5.3. We should be doing a refresh of that backport for 5.4 (separate BZ).
Comment 4 IBM Bug Proxy 2009-02-27 19:30:34 EST
(In reply to comment #7)
> Note that ext4 is also out in tech preview in RHEL5.3. We should be doing a
> refresh of that backport for 5.4 (separate BZ).
>

Ric, We had validated ext4 on RHEL5.3 it seems good.

When a separete BZ is created to backport ext4 for 5.4, we could help on backport and validate.

Mingming
Comment 5 IBM Bug Proxy 2009-10-07 09:40:59 EDT
------- Comment From mgrf@de.ibm.com 2009-10-07 09:33 EDT-------
(In reply to comment #7)
> Note that ext4 is also out in tech preview in RHEL5.3. We should be doing a
> refresh of that backport for 5.4 (separate BZ).
>

Hello Red Hat:
Question:
Do you plan to fully support ext4 with RHEL6,
or will it be a tech. preview like with RHEL 5?
Comment 6 John Jarvis 2009-10-09 10:30:13 EDT
In RHEL 6.0 Ext4 will be fully supported.
Comment 7 John Jarvis 2009-10-15 10:59:40 EDT
IBM is signed up to test and provide feedback
Comment 8 IBM Bug Proxy 2009-11-17 16:40:45 EST
Moving to Accepted state since this is now set to modified on RH side.
Comment 14 IBM Bug Proxy 2010-05-21 14:50:39 EDT
------- Comment From djwong@us.ibm.com 2010-05-21 14:47 EDT-------
As of 21 May 2010 (kernel 2.6.32-23.el6.x86_64) I can confirm that ext4 exists as a kernel module and installer option.  Preallocation seems to be working, > 2TB file sizes seem to be working, and fast fsck seems to be working.
Comment 15 releng-rhel@redhat.com 2010-11-11 09:41:35 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.