Bug 463795 - [LTC 6.0 FEAT] 201184:Provide DFP hardware accelerated libgcc
[LTC 6.0 FEAT] 201184:Provide DFP hardware accelerated libgcc
Status: CLOSED DUPLICATE of bug 464229
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution (Show other bugs)
6.0
s390x All
high Severity high
: alpha
: 6.0
Assigned To: RHEL Product and Program Management
Daniel Riek
: FutureFeature
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2008-09-24 14:40 EDT by IBM Bug Proxy
Modified: 2009-12-16 15:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-16 15:10:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 14:40:38 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:50 EDT
1. Feature Overview:
Feature Id:	[201184]
a. Name of Feature:	Provide DFP hardware accelerated libgcc
b. Feature Description
A hardware dfp accelerated libgcc is installed parallel to the normal version in order to allow dfp
applications to switch at load time to dfp acceleration and therefore provide applications which are
able to run on non hw dfp machines as well.

Additional Comments:	This feature is satisfied when gcc 4.4 get included into distro

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Toolchain: Yes
Delivery Mechanism: Direct from community
Category:	Toolchain
Request Type:	Toolchain - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	gcc 4.4 (+backport for gcc 4.3)

3. Business Case
Increase Flexibility for Independent Software Vendors and their developers to only build one version
of their product running DFP operations.  With a hardware accelerated libgcc variant application
just have to be built once and will be provided with hardware accelerated arithmetic operations
using libgcc. On machines without dfp hardware instruction the standard software implementation from
the decNumber library will be used.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-03-04 08:20:50 EST
This is accepted upstream with gcc 4.4

When RHEL 6 takes gcc 4.4 this feature is fulfilled
Comment 2 Jakub Jelinek 2009-09-18 06:10:29 EDT
I thought that dfp stuff is moving into libdfp from libgcc...

RHEL6 alpha is gcc 4.4 based in any case.
Comment 3 IBM Bug Proxy 2009-09-22 05:50:43 EDT
------- Comment From mgrf@de.ibm.com 2009-09-22 05:42 EDT-------
Yes this is part of the additional libdfp now
Comment 4 Jakub Jelinek 2009-09-30 14:26:12 EDT
Reassigning to libdfp then.
Comment 5 John Jarvis 2009-12-16 15:10:56 EST

*** This bug has been marked as a duplicate of bug 464229 ***

Note You need to log in before you can comment on or make changes to this bug.