Bug 463797 - unnecessary and poorly phrased notification
unnecessary and poorly phrased notification
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-09-24 14:42 EDT by Colin Walters
Modified: 2008-10-07 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-07 12:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2008-09-24 14:42:28 EDT
Started a rawhide desktop live image, and got some sort of input-related notification showing up on the screen by default.  This is not acceptable and we need to figure out a way to improve the situation.

If the problem is that for some locales we need to choose an input system, one idea is to inspect $LANG and choose a default mechanism from that.
Comment 1 Akira TAGOH 2008-09-24 23:47:33 EDT
This might be somehow related to Bug#460703. the status icon (and notification as well) is hidden by default in next release. you also won't see the unnecessary notifications once you click the do-not-show-notification-again button in the bubble popup.
Comment 2 Akira TAGOH 2008-09-25 03:34:23 EDT
Fixed in imsettings-0.104.1-1.fc10.
Comment 3 Colin Walters 2008-09-30 09:56:24 EDT
So there is still a notification by default?  I'm not very happy with that[1] - can we have a discussion about how we could design the system so that it would be usable for people who need the input system but not pop up even one notification for people who don't?

What about my suggestion of having per-$LANG logic?
Comment 4 Akira TAGOH 2008-09-30 22:16:25 EDT
Not exactly. when the status icon is hidden, it doesn't notify anything at all. and the status icon isn't displayed by default. one who don't need input method, including you won't see a notification anymore. if it does, it's not expected behaviour and is a bug.

I'm afraid I don't think per-$LANG logic is a good idea, because the applet is to change input method temporarily on the desktop and that prevents people who want it but usually living in the language outside expected languages to show up.  therefore I have chosen the above approach to give an option, and one who really want to see/use that could enable to see the status icon and a notification.
Comment 5 Matthias Clasen 2008-10-04 00:16:53 EDT
This seems to work correctly for me now. 
I see notify_on_bubble default to true, and show_icon default to false.
And if I start imsettings-applet with those values, I see neither the icon, nor the bubble.

Colin, can you confirm that it works correctly now ?
Comment 6 Matthias Clasen 2008-10-07 12:34:45 EDT
Closing, to get it off the bug lists

Note You need to log in before you can comment on or make changes to this bug.