Bug 463829 - Add the common matroska container extensions to the mediafiles patch
Add the common matroska container extensions to the mediafiles patch
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: bash-completion (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 16:15 EDT by Yanko Kaneti
Modified: 2009-05-02 12:30 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for the mediafiles patch (1.61 KB, patch)
2008-09-24 16:15 EDT, Yanko Kaneti
no flags Details | Diff
mka and mkv only (1.61 KB, patch)
2008-09-25 12:22 EDT, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Yanko Kaneti 2008-09-24 16:15:13 EDT
Created attachment 317621 [details]
patch for the mediafiles patch

Please add the common matroska container extensions (mka,mkv,mks) to the mediafiles patch. MKV is quite popular in the scene.
Comment 1 Ville Skyttä 2008-09-25 11:25:50 EDT
Good idea.  But I've never heard of mks before this, and would like to test that they actually do something useful when opened with a media player (.mks are subtitle streams, right?) but I'm unable to find any samples to try out.  Could you point me to one?
Comment 2 Yanko Kaneti 2008-09-25 12:22:39 EDT
Created attachment 317707 [details]
mka and mkv only

You are quite right. I rushed and presumed the S meant "stream" without any examples at hand. Attaching new patch only for mka and mkv. Although to be fair I don't think I've ever seen a mka file.
Comment 3 Ville Skyttä 2008-09-25 14:13:20 EDT
Ok, thanks.  But now that I test, I'm unable to get any xine based players to play any *.mkv or *.mka whatsoever.  Do they work for you e.g. in xine or kaffeine?
Comment 4 Yanko Kaneti 2008-09-25 15:17:01 EDT
yup, xine in rawhide plays mkv for me. (with the slight quirk of -A alsa because the pulseaudio plugin dies on me #447422)
....
gui_xine_open_and_play():
	mrl: 'XXXXXXXXXXXX.mkv',
	sub 'NONE',
	start_pos 0, start_time 0, av_offset 0, spu_offset 0.
xine: found input plugin  : file input plugin
xine: found demuxer plugin: matroska demux plugin
demux_matroska: Track 1, V_MPEG4/ISO/AVC eng
demux_matroska: Track 2, A_AC3 und
.....
Comment 5 Ville Skyttä 2008-09-25 16:09:22 EDT
Ok, I got mkv playing with xine and kaffeine.  No pulseaudio here either (even installed) but it didn't make a difference, but for some reason changing video.driver to xv instead of auto (which eventually picked xv) appears to have fixed it, go figure.

But *.mka still won't play with xine/kaffeine for me (xine --verbose outputs some ebml errors), whereas with mplayer they do (will add mka to its completions).  I uploaded a small sample to http://scop.fedorapeople.org/tmp/foo.mka - could you test if you can hear it with xine?
Comment 6 Yanko Kaneti 2008-09-25 18:05:05 EDT
Same here. 

gui_xine_open_and_play():
	mrl: 'foo.mka',
	sub 'NONE',
	start_pos 0, start_time 0, av_offset 0, spu_offset 0.
xine: found input plugin  : file input plugin
xine: found demuxer plugin: matroska demux plugin
demux_matroska: Track 1, A_PCM/INT/LIT und
av_offset=0 pts
spu_offset=0 pts
ebml: read error

and nothing.
Comment 7 Ville Skyttä 2008-10-02 15:28:47 EDT
Ok, thanks for the confirmation.  mkv added for xine based players and mka for mplayer (mkv was already there) in CVS, will be in the next post -13 build.
Comment 8 Bug Zapper 2008-11-25 22:12:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Fedora Update System 2009-04-13 09:11:33 EDT
bash-completion-1.0-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/bash-completion-1.0-2.fc10
Comment 10 Fedora Update System 2009-04-13 09:12:56 EDT
bash-completion-1.0-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/bash-completion-1.0-2.fc9
Comment 11 Fedora Update System 2009-04-14 11:51:49 EDT
bash-completion-1.0-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update bash-completion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-3639
Comment 12 Fedora Update System 2009-04-14 11:52:07 EDT
bash-completion-1.0-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update bash-completion'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-3640
Comment 13 Fedora Update System 2009-05-02 12:25:44 EDT
bash-completion-1.0-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2009-05-02 12:30:15 EDT
bash-completion-1.0-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.