Bug 463836 - [LTC 6.0 FEAT] 201195:Scaled utilisation metrics for power-managed systems
[LTC 6.0 FEAT] 201195:Scaled utilisation metrics for power-managed systems
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
medium Severity medium
: alpha
: ---
Assigned To: James Takahashi
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 525727
  Show dependency treegraph
 
Reported: 2008-09-24 16:40 EDT by IBM Bug Proxy
Modified: 2010-10-18 15:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 17:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 48458 None None None Never

  None (edit)
Description IBM Bug Proxy 2008-09-24 16:40:49 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:52 EDT
1. Feature Overview:
Feature Id:	[201195]
a. Name of Feature:	Scaled utilization metrics for power-managed systems
b. Feature Description
Provide correct utilization metrics as a function of total CPU capacity.  For example utilization
may be relative to highest nominal state or to current power cap.  This may also impact a number of
system utilities (eg: ps, top, others...).  Currently CPU frequency scaling for power management may
cause CPU utilization metrics to become incorrect.

2. Feature Details:
Sponsor:	LTC
Architectures:
x86
x86_64
ppc64

Arch Specificity: Both
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	Kernel
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	2.6.25

3. Business Case
Sophisticated enterprise-level system and cluster management products need accurate accounting to
correctly manage CPU resource utilization versus power utilization.  Increasingly the enterprise
market is interested in mitigating and managing power consumption in servers, where interest
previously was mostly in a mobile market.  An enterprise Linux distribution which enables
sophisticated monitoring and control applications will have an advantage in this emerging market.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Dipankar Sarma, dipankar.sarma@in.ibm.com
Gautham R Shenoy, gautshen@in.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 Bill Nottingham 2008-09-24 16:49:53 EDT
What configuration options, if any, are needed for this? How is it exposed to userspace for apps to use?
Comment 2 IBM Bug Proxy 2009-03-05 12:50:45 EST
(In reply to comment #4)
> What configuration options, if any, are needed for this? How is it exposed to userspace for apps to use?

CONFIG_VIRT_CPU_ACCOUNTING=y once the chargeback accounting patches show up in mainline.  The taskstats netlink interface is how one gets advanced utime/stime data; see getdelays.c for a simple example of how it works.  The utime/stime numbers will be scaled down (or up) based on the p-state when the processor is in C0.
Comment 3 Jesse Larrew 2009-06-29 18:42:54 EDT
Assigning this to Peter Bogdanovic at IBM.
Comment 4 Peter Bogdanovic 2009-09-17 17:21:57 EDT
Support for Power processors upstream in 2.6.31.  Support of Intel and AMD processors unlikely in RHEL6.0 because the cpus don't support it properly.
Comment 5 IBM Bug Proxy 2009-11-18 08:10:30 EST
Reassigning to Darrick, please answer Red Hat's question and move bug to Submitted state afterwards.

Since in RH cvs tree, moving to Accepted state

Note You need to log in before you can comment on or make changes to this bug.