Bug 463843 - AttributeError: 'NoneType' object has no attribute 'pesize'
AttributeError: 'NoneType' object has no attribute 'pesize'
Status: CLOSED DUPLICATE of bug 463780
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Brock Organ
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 16:59 EDT by Jeff Burke
Modified: 2008-09-25 09:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 09:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full failure from anaconda (113.60 KB, text/plain)
2008-09-24 16:59 EDT, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2008-09-24 16:59:50 EDT
Created attachment 317624 [details]
Full failure from anaconda

Description of problem:
While installing RHEL5.3-Server-20080919.1 I manually tried to change the size of the LVM volume. When I did that an exception occurred.

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080919.1

How reproducible:
Always

Steps to Reproduce:
1. Manually manipulate the default LVM Group  
  
Actual results:
Traceback (most recent call first):
  File "/usr/lib/anaconda/partRequests.py", line 981, in getActualSize
    retval = lvm.clampLVSizeRequest(retval, vgreq.pesize)
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 445, in editLogicalVolume
    sizeEntry.set_text("%Ld" % (logrequest.getActualSize(self.partitions, self.diskset),))
  File "/usr/lib/anaconda/iw/lvm_dialog_gui.py", line 764, in addLogicalVolumeCB
    self.editLogicalVolume(request, isNew = 1)
AttributeError: 'NoneType' object has no attribute 'pesize'

Additional info:
Comment 1 Radek Vykydal 2008-09-24 17:28:36 EDT
seems like same issue as #463780
Comment 2 Radek Vykydal 2008-09-25 09:34:57 EDT

*** This bug has been marked as a duplicate of bug 463780 ***

Note You need to log in before you can comment on or make changes to this bug.