This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 463852 - PS3 wireless driver disabled in wpa_supplicant
PS3 wireless driver disabled in wpa_supplicant
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 17:31 EDT by Jacek Fedorynski
Modified: 2008-10-01 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 12:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jacek Fedorynski 2008-09-24 17:31:12 EDT
As of 0.6.4, wpa_supplicant includes a driver for the wifi chip in the PS3, thus allowing the use of WPA encryption on the platform. However, the driver is currently disabled in Fedora.

The fix should be as simple as adding CONFIG_DRIVER_PS3=y to the config file.
Comment 1 Dan Williams 2008-09-25 12:36:43 EDT
The WEXT driver should work correctly with the PS3 Gelic wireless driver as of 2.6.27 kernel and wpa_supplicant 0.6.4, both of which ship with rawhide.  The "ps3" wpa_supplicant driver is deprecated as it was used before the kernel had WEXT support for IW_ENC_CAPA_4WAY_HANDSHAKE.  Please let me know if the WEXT driver doesn't work by reopening this bug, and then we'll try to pin down where the problem is.
Comment 2 Jacek Fedorynski 2008-10-01 19:27:29 EDT
Indeed, in F10 Beta, WPA works out of the box. Thanks.

Note You need to log in before you can comment on or make changes to this bug.