Bug 463857 - python-pyblock no longer builds
python-pyblock no longer builds
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-pyblock (Show other bugs)
5.4
All Linux
medium Severity high
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 18:21 EDT by Doug Chapman
Modified: 2009-04-24 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 11:41:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix build error (457 bytes, patch)
2008-09-24 18:21 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-09-24 18:21:20 EDT
Created attachment 317627 [details]
patch to fix build error

Description of problem:
python-pyblock no longer builds:


gcc -g -I/usr/include/python2.4 -Wall -Werror -fPIC -DUSESELINUX=1 -c -o dmraid.o dmraid.c
cc1: warnings being treated as errors
dmraid.c: In function ‘pydmraid_ctx_discover_raidsets’:
dmraid.c:1248: warning: passing argument 2 of ‘group_set’ from incompatible pointer type
make: *** [dmraid.o] Error 1


I will attach a patch that doe what I think was intended.


Version-Release number of selected component (if applicable):
python-pyblock-0.26-1.el5


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Joel Andres Granados 2008-09-25 17:00:41 EDT
I guess once you build it in RHEL5.3 it breaks.  I built it in RHEL5.2 and had no problems.  More over did  a scratch build with build target "dist-5E-build".
Comment 2 Joel Andres Granados 2009-04-24 11:41:26 EDT
We are currently in python-pyblock-0.26-4.el5 and it built for me in brew.  I think we can safely close this bug.

Note You need to log in before you can comment on or make changes to this bug.