Bug 463875 - [LTC 6.0 FEAT] 200973:Improve the availability of the system by reducing the boot time
[LTC 6.0 FEAT] 200973:Improve the availability of the system by reducing the ...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All All
medium Severity medium
: alpha
: ---
Assigned To: Jesse Larrew
Martin Jenner
:
Depends On:
Blocks: 356741 RHEL6Kernel2.6.27
  Show dependency treegraph
 
Reported: 2008-09-24 23:10 EDT by IBM Bug Proxy
Modified: 2009-06-20 02:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-03 13:53:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-24 23:10:26 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:52 EDT
1. Feature Overview:
Feature Id:	[200973]
a. Name of Feature:	Improve the availability of the system by reducing the boot time
b. Feature Description
This feature deals with the general high-uptime/high-availability requirement by speeding up the
kernel re-boot process, especially for the main device subsystems such as SCSI and PCI.    In the
Linux Kernel community there have been few attempts like a patch (from Matthew Wilcox) floating on
the Linux-scsi mailing list that provides the asynchronous scanning feature. Another patch (from
Greg KH) on LKML providing for a parallel driver->device probe() method. Both are already part of
mainline now.    The proposed feature is being designed to use fastboot features like kexec, to take
a snapshot of the devices during a normal cold boot and during a reboot, the snapshot is replayed so
that the device-id's which were not present in first boot and not probed during reboot. This
mechanism avoids the timeouts happening during probing devices which are  not present. This feature
will be effective if there are no changes in the device hardware topology between boots.

Additional Comments:	Code under review

2. Feature Details:
Sponsor:	Linux Systems Tech
Architectures:
x86
x86_64
ppc64

Arch Specificity: Both
Affects Kernel Modules: Yes
Delivery Mechanism: Direct from community
Category:	RAS
Request Type:	Kernel - Enhancement from IBM
d. Upstream Acceptance:	In Progress
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	upstream kernel v2.6.27

3. Business Case
With this feature in place, field service engineers get more service time with IBM hardware without
adversely impacting customer SLAs. In other words, this translates to more reboot cycles without
additional downtime, which is important if the field engineer is trying out a fix in a customer
environment, updating customer installs to latest service levels or applying security updates.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Mounir Bsaibes, bsaibes@us.ibm.com, 512-838-1301

Technical contact(s):
Maneesh Soni, smaneesh@in.ibm.com
Ananth N Mavinakayanahall, mananth@in.ibm.com

IBM Manager:
Naren A Devaiah, naren.devaiah@in.ibm.com
Comment 1 Bill Nottingham 2008-10-03 13:21:53 EDT
Just to clarify - the asynchronous scanning and parallel probing are in 2.6.27, or your device snapshot feature is in 2.6.27?
Comment 2 IBM Bug Proxy 2008-10-06 10:36:55 EDT
Bill,
Asynchronous scanning has been part of the upstream kernel for a long time now. This new feature will provide the device tree snapshotting feature that'll work only across kexec reboots.
Comment 3 Bill Nottingham 2008-10-06 15:06:07 EDT
OK. Putting in NEEDINFO pending upstream code submission - or did this make 2.6.27?
Comment 4 IBM Bug Proxy 2009-01-29 06:30:43 EST
Closing this feature bug. The feature request is also in "quit". The reason being the alternate solution available with community which has broader scope in reducing the boot time. The patches are available in community at this git tree http://kernel.org/pub/scm/linux/kernel/git/arjan/linux-2.6-async.git
Comment 5 Peter Martuccelli 2009-02-03 13:53:52 EST
Closing out the request as per comment #4.

Note You need to log in before you can comment on or make changes to this bug.