This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 463895 - Modeset produces whitescreen an laptop display radeon x700
Modeset produces whitescreen an laptop display radeon x700
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 03:12 EDT by jon
Modified: 2008-11-15 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-15 17:12:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of lspci -vn (9.61 KB, text/plain)
2008-09-25 03:12 EDT, jon
no flags Details
output dmidecode (23.30 KB, text/plain)
2008-09-25 03:14 EDT, jon
no flags Details
dmesg drm debug radeon modeset (14.03 KB, text/plain)
2008-09-25 03:16 EDT, jon
no flags Details
xorg.log nomodeset (45.01 KB, text/plain)
2008-09-25 03:20 EDT, jon
no flags Details
xorg.log modeset (35.16 KB, text/plain)
2008-09-25 03:21 EDT, jon
no flags Details

  None (edit)
Description jon 2008-09-25 03:12:02 EDT
Created attachment 317658 [details]
output of lspci -vn

Description of problem:
When testing the new kernel-based modeset functionality on an laptop with an x700 mobility the laptopscreen goes white. Booting with "nomodeset" lets X startup normal.
This happens on an Fujitsu-Siemens Amilo A1667G Laptop. (Turion 64 ML34, KT 800, X700 mobility)
Also happens when booting the F-10 Alpha Live-CD

Version-Release number of selected component (if applicable):
2.6.27-0.352.rc7.git1.fc9.x86_64 (recompiled koji-package on Fedora 9), also recompiled xorg, mesa, libdrm and xorg-drv-ati with latest koji-packages.

How reproducible:
On the above Hardware boot either the F-10 LiveCD, or boot with the koji-packages.

Steps to Reproduce:
1. Boot F-10 Alpha / Rawhide on the above hardware without nomodeset
2.
3.
  
Actual results:
Laptopscreen goes white

Expected results:
It should display the framebuffer console and later the Xorg-Display

Additional info:
Added lspci -vn, dmidecode and dmesg with drm debug=1, also added Xorg.log with nomodeset and modeset as attachment
Comment 1 jon 2008-09-25 03:14:26 EDT
Created attachment 317659 [details]
output dmidecode
Comment 2 jon 2008-09-25 03:16:59 EDT
Created attachment 317660 [details]
dmesg drm debug radeon modeset
Comment 3 jon 2008-09-25 03:20:03 EDT
Created attachment 317661 [details]
xorg.log nomodeset
Comment 4 jon 2008-09-25 03:21:02 EDT
Created attachment 317662 [details]
xorg.log modeset
Comment 5 Christopher D. Stover 2008-11-15 17:12:42 EST

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.