Bug 463919 - cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory during yum upgrade
cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or dir...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openmpi (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Martin Jenner
:
Depends On:
Blocks: RHEL5u3_relnotes
  Show dependency treegraph
 
Reported: 2008-09-25 09:10 EDT by Alexander Todorov
Modified: 2009-02-22 18:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When upgrading openmpi using yum, the following warning may be returned: cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory The message is harmless and can be safely ignored.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-22 18:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-09-25 09:10:43 EDT
Description of problem:
Error message generated while upgrading from RHEL5.2 to 5.3 with yum

Version-Release number of selected component (if applicable):
openmpi-1.2.7-2.el5

How reproducible:
always

Steps to Reproduce:
1. Install RHEL5.2, Server repo only (key --skip), @everything
2. Upgrade to latest 5.3 trees
  
Actual results:
Error in the yum output, most probably related to openmpi

Expected results:
No errors in yum's output.

Additional info:
The text looks like:

Cleanup   : glibc-devel                  ################### [ 970/1195] 
Cleanup   : dbus-x11                     ################### [ 971/1195]head: cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory
/var/tmp/rpm-tmp.53668: line 25: [: 8263VERSION: integer expression expected
rm: cannot remove `/tmp/openmpi-upgrade-version.*': No such file or directory
 
Cleanup   : openmpi-libs                 ################### [ 972/1195] 
Cleanup   : mesa-libOSMesa-devel         ################### [ 973/1195]
Comment 3 Alexander Todorov 2008-09-25 09:55:38 EDT
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
When upgrading previous versions of openmpi a message of the type

"cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory" can be seen in in yum's output.

The message is harmless and can be safely ignored.
Comment 6 Ryan Lerch 2008-10-08 20:54:15 EDT
Release note updated. If any revisions are required, please set the 
"requires_release_notes"  flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

Diffed Contents:
@@ -1,5 +1,5 @@
-When upgrading previous versions of openmpi a message of the type
+When upgrading openmpi using yum, the following warning may be returned:
 
-"cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory" can be seen in in yum's output.
+cannot open `/tmp/openmpi-upgrade-version.*' for reading: No such file or directory
 
 The message is harmless and can be safely ignored.

Note You need to log in before you can comment on or make changes to this bug.