Bug 463933 - Power 6 LPAR-ehea(Network driver) not detected during the installation of Fedora 10-Alpha
Power 6 LPAR-ehea(Network driver) not detected during the installation of Fed...
Status: CLOSED DUPLICATE of bug 496820
Product: Fedora OLPC
Classification: Retired
Component: kernel (Show other bugs)
ppc64 All
medium Severity urgent
: ---
: ---
Assigned To: John (J5) Palmieri
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-09-25 11:10 EDT by IBM Bug Proxy
Modified: 2013-03-13 00:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-02 18:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot showing NetworkManager tring to configure eth0 (1.23 MB, image/png)
2008-11-28 05:42 EST, IBM Bug Proxy
no flags Details
Screenshot showing NetworkManager failed to configure the network (1.24 MB, image/png)
2008-11-28 05:42 EST, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2008-09-25 11:10:58 EDT
Problem description:
During installation of Fedora 10-Alpha on  Power-6(llm62), I found the installer
already installed ehea power6 network driver. But installer unable to use the
driver to do NFS installation. Giving a call trace as shown below.

As I was unable to network boot with yaboot of fedora I have used yaboot of
opensuse-11-Alpha1 as alternative.

Network server Files:

detecting hardware...
waiting for hardware to initialize...
Oops: Kernel access of bad area, sig: 11 [#1]
SMP NR_CPUS=128 NUMA pSeries
Modules linked in: ehea(+) ipv6 iscsi_tcp libiscsi scsi_transport_iscsi ext2
ext3 jbd ext4dev jbd2 mbcache crc16 squashfs loop nfs lockd nfs_acl sunrpc vfat
fat cramfs
NIP: d0000000002e87fc LR: d0000000002e87b8 CTR: c00000000000915c
REGS: c00000008017b1a0 TRAP: 0300   Tainted: G        W 
MSR: 8000000000009032 <EE,ME,IR,DR>  CR: 24222484  XER: 00000020
DAR: 6b6b6b6b6b6bc973, DSISR: 0000000040000000
TASK = c0000000800f5200[1038] 'modprobe' THREAD: c000000080178000 CPU: 3
GPR00: c00000008098ea08 c00000008017b420 d00000000030abb0 0000000000000001 
GPR04: d0000000002fd150 0000000000000000 0000000000000000 6b6b6b6b6b6b6b6b 
GPR08: c00000008098e910 6b6b6b6b6b6b6b6b 0000000000000008 0000000000000000 
GPR12: d0000000002f3ba8 c00000000092fa00 d0000000002fda50 c00000008017bca0 
GPR16: d00000000027f460 00000000000001fd 0000000000000000 d00000000027ed68 
GPR20: 0000000000000124 0000000000000025 c0000000fffff9c0 c00000008098e9d0 
GPR24: c0000000049c3508 0000000000000000 d0000000002fcfe0 fffffffffffffffb 
GPR28: c00000008304b7a8 d0000000002fcfe0 d000000000309c80 c00000008017b420 
NIP [d0000000002e87fc] .ehea_update_firmware_handles+0x98/0x404 [ehea]
LR [d0000000002e87b8] .ehea_update_firmware_handles+0x54/0x404 [ehea]
Call Trace:
[c00000008017b420] [d0000000002e87b8] .ehea_update_firmware_handles+0x54/0x404
[ehea] (unreliable)
[c00000008017b510] [d0000000002f3004] .ehea_probe_adapter+0x3b0/0x3fc [ehea]
[c00000008017b5d0] [c00000000045b6f4] .of_platform_device_probe+0x94/0xd0
[c00000008017b670] [c00000000036f248] .driver_probe_device+0x124/0x210
[c00000008017b710] [c00000000036f3a4] .__driver_attach+0x70/0xb8
[c00000008017b7b0] [c00000000036e644] .bus_for_each_dev+0x98/0x100
[c00000008017b880] [c00000000036ef94] .driver_attach+0x40/0x60
[c00000008017b910] [c00000000036dbc0] .bus_add_driver+0xdc/0x294
[c00000008017b9c0] [c00000000036f798] .driver_register+0xf4/0x1d0
[c00000008017ba70] [c00000000045b534] .of_register_driver+0x60/0x80
[c00000008017bb00] [c000000000029644] .ibmebus_register_driver+0x40/0x60
[c00000008017bb90] [d0000000002f3234] .ehea_module_init+0x1e4/0x24a8 [ehea]
[c00000008017bc20] [c0000000000df608] .sys_init_module+0x18d4/0x1a98
[c00000008017be30] [c000000000008770] syscall_exit+0x0/0x40
Instruction dump:
38c00000 389d0170 e93d0170 3909ff08 48000058 39400000 7d285214 394a0008 
2f2a0080 e9290010 2fa90000 419e002c <80095e08> 2f800001 409e0020 80095dd8 
---[ end trace 084d9051eaff1cab ]---
modprobe used greatest stack depth: 8192 bytes left
Welcome to Fedora for ppc

            +-----------------+ No driver found +------------------+            
            |                                                      |            
            |       Unable to find any devices of the type         |            
            |       needed for this installation type.             |            
            |       Would you like to manually select your         |            
            |       driver or use a driver disk?                   |            
            |                                                      |            
            | +---------------+   +-------------------+  +------+  |            
            | | Select driver |   | Use a driver disk |  | Back |  |            
            | +---------------+   +-------------------+  +------+  |            
            |                                                      |            
            |                                                      |            

  <Tab>/<Alt-Tab> between elements  | <Space> selects | <F12> next screen

Hardware Environment
    Machine type (p650, x235, SF2, etc.):llm62
    Cpu type (Power4, Power5, IA-64, etc.): Power 6
    Describe any special hardware you think might be relevant to this problem:



Please we are looking for information about this situation. 

Thank you
Comment 1 IBM Bug Proxy 2008-09-30 07:31:58 EDT
I could reproduce this issue again in Fedora10 Beta.
Comment 2 IBM Bug Proxy 2008-10-03 02:16:16 EDT
Redhat team,
Any updates here..
Thanks, Supriya
Comment 3 IBM Bug Proxy 2008-10-13 06:01:21 EDT
Redhat Team
Any updates here..
Thanks, Supriya
Comment 4 IBM Bug Proxy 2008-11-07 05:30:27 EST
Same issue repeated in F10 Preview.
Comment 5 IBM Bug Proxy 2008-11-13 12:51:01 EST
Redhat team,
Any updates here?
Comment 6 IBM Bug Proxy 2008-11-18 06:30:40 EST
RedHat, any update on this issue ?
Comment 7 IBM Bug Proxy 2008-11-28 05:41:59 EST
Still getting the issue in Fedora 10.

This time did not use the yaboot itself and still getting the network issue
Booted  from OF prompt as shown below

0 > boot /lhea@23c00200/ethernet@23e00100:bootp,,ppc64.img,,,5,5,
Comment 8 IBM Bug Proxy 2008-11-28 05:42:08 EST
Created attachment 324965 [details]
Screenshot showing NetworkManager tring to configure eth0
Comment 9 IBM Bug Proxy 2008-11-28 05:42:17 EST
Created attachment 324966 [details]
Screenshot showing NetworkManager failed to configure the network
Comment 10 IBM Bug Proxy 2008-12-16 03:11:39 EST
Redhat Team,
This issue is been there in Fedora alpha, recreated in Fedora beta and preview. Waiting for your inputs...
Thanks, Supriya
Comment 11 IBM Bug Proxy 2008-12-16 04:01:40 EST
We have this issue in F10 Final release also.

Comment 12 skierpage 2009-03-14 22:10:49 EDT
"Product=Fedora OLPC" is wrong for this bug.

Besides, I think "Fedora OLPC" is a retired product, bugs with the OLPC XO-1 laptop are tracked by the FedoraOnXO tracker bug #461806.

Bug #438213 has the same incorrect product.
Comment 13 IBM Bug Proxy 2009-04-08 03:01:51 EDT
------- Comment From skannery@in.ibm.com 2009-04-08 02:59 EDT-------
Pavan informed that we could close this issue for now and he will be seeing to open a fresh one.
Closing this issue
Comment 14 Dan Williams 2009-06-02 18:21:39 EDT

*** This bug has been marked as a duplicate of bug 496820 ***

Note You need to log in before you can comment on or make changes to this bug.