Bug 463944 - rpm writes error : File not found by glob: and return code = 0
rpm writes error : File not found by glob: and return code = 0
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rpm (Show other bugs)
5.2
All Linux
medium Severity medium
: beta
: ---
Assigned To: Panu Matilainen
BaseOS QE
:
: 446202 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 12:30 EDT by Petr Sklenar
Modified: 2009-01-20 15:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 15:49:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2008-09-25 12:30:28 EDT
Description of problem:
rpm writes error but return code is zero

Version-Release number of selected component (if applicable):
rpm-4.4.2.3-5.el5

How reproducible:
always

Steps to Reproduce:
1. i didnt mounted any folder, so file wasnt on that path
2. 
#rpm -Uv  /mnt/redhat/brewroot/packages/openssl/0.9.8b/8.3.el5/x86_64/openssl-0.9.8b-8.3.el5.*.rpm 
error: File not found by glob: /mnt/redhat/brewroot/packages/openssl/0.9.8b/8.3.el5/x86_64/openssl-0.9.8b-8.3.el5.*.rpm
3. echo $?
0 

4. in folder /usr/src/redhat/RPMS/x86_64/ is nothing:

#rpm -Uvh  /usr/src/redhat/RPMS/`uname -i`/*
error: File not found by glob: /usr/src/redhat/RPMS/x86_64/*
# echo $?
0


Actual results:

it writes echo $?=0 during error

Expected results:
return code should be nonzero

Additional info:
Comment 1 Panu Matilainen 2008-09-26 03:55:33 EDT
*** Bug 446202 has been marked as a duplicate of this bug. ***
Comment 2 Panu Matilainen 2008-09-26 03:57:12 EDT
Fixed upstream so patch already exists, easy fix.
Comment 12 errata-xmlrpc 2009-01-20 15:49:10 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0079.html

Note You need to log in before you can comment on or make changes to this bug.