Bug 463957 - SQL Queries are not properly localized.
SQL Queries are not properly localized.
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks: space08
  Show dependency treegraph
 
Reported: 2008-09-25 13:44 EDT by Chris
Modified: 2010-02-16 07:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 11:21:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2008-09-25 13:44:54 EDT
Description of problem: SQL Queries are not properly localized.


Version-Release number of selected component (if applicable): 0.2


How reproducible: Changing system locales to other than en_EN and en_US, for me it was pl_PL, install oracle-xe wich has proper National Language Settings for polish language. Spacewalk installation will crash.


Steps to Reproduce:
1. Change system locales to pl_PL
2. Install Oracle-xe-univ in this environment 
3. Verify that oracle is in Polish language
4. Try to install spacewalk, installation will crash
  
Actual results:
Spacewalk install:
*** Progress: ###############################
* Performing initial configuration.
* Activating Satellite.
** Loading Satellite Certificate.
** Verifying certificate locally.
** Activating Satellite.
There was a problem activating the satellite: Local activation failure.

rhn-installation.log:

ERROR: RHN Entitlement Certificate failed to validate:
Exception reported from test.domek.aster.pl
Time: Mon Sep 22 12:19:37 2008
Exception type server.rhnSQL.sql_base.SQLSchemaError

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/satellite_tools/rhn_satellite_activate.py", line 203,
in activateSatellite_local
    satCerts.storeRhnCert(cert, check_generation=1,
check_version=not(options.ignore_version_mismatch))
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 228, in
storeRhnCert
    create_first_org(owner=sc.owner)
  File "/usr/share/rhn/satellite_tools/satCerts.py", line 97, in
create_first_org
    p(owner, pword)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 38, in __call__
    retval = self._call_proc(args)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 249, in
_call_proc
    return self._call_proc_ret(args, ret_type=None)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 270, in
_call_proc_ret
    raise sql_base.SQLSchemaError(e.code, e.message, e.context)
SQLSchemaError: (6550, 'ORA-06550: line 1, column 7:', "PLS-00201:
identifier 'CREATE_FIRST_ORG' must be declared\nORA-06550: line 1, column 7
:\nPL/SQL: Statement ignored\n", 'Cursor_InternalExecute()')

In populate_db.log I've got:

SQL_FILE
--------------------------------
rhnsat/tables/rhnFAQ_satdata.sql

, 1,  TO_Date( '10/02/2002 12:00:00 AM', 'MM/DD/YYYY HH:MI:SS AM'), 
TO_Date( '05/12/2003 10:18:24 PM', 'MM/DD/YYYY HH:MI:SS AM')
               *
Erorr at line 4:
ORA-01855: AM/A.M. or PM/P.M. required


Expected results: Proper installation


Additional info: Adding alter session set NLS_LANGUAGE='AMERICAN'; to the /etc/sysconfig/rhn/*.sql files solves the problem but applications queries still generates warnings and errors.
Comment 1 Michael Mráka 2010-01-27 11:21:33 EST
The issue is not reproducible in current release - Spacewalk 0.7. Closing now.
Feel free to reopen if the bug is not fixed.
Comment 2 Michael Mráka 2010-02-16 07:59:09 EST
Spacewalk 0.8 has been released

Note You need to log in before you can comment on or make changes to this bug.