Bug 463965 - Problem with Certs generation during installation process.
Problem with Certs generation during installation process.
Status: CLOSED NOTABUG
Product: Spacewalk
Classification: Community
Component: Installation (Show other bugs)
0.2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-09-25 14:02 EDT by Chris
Modified: 2009-02-24 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 17:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2008-09-25 14:02:21 EDT
Description of problem: Certificate that is generated during installation process is wrong and client can't use a ssl connection. 


Version-Release number of selected component (if applicable): 0.2


How reproducible: Don't know. I've installed spacewalk, configured and tried to download the rpm with certificate. RPM successfully downloaded and installed but when I tried to use rhn tools to register client threw ssl connection it always says that the certificate is wrong.


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Wrong certificate. Can't use an ssl connection during client installation.


Expected results:
Possibility of using SSL connection while registering clients.

Additional info: none
Comment 2 Pradeep Kilambi 2009-02-24 17:10:08 EST
Sounds to me like the client is looking at the wrong certfile. 

Try these steps and lemme know if you still see this:

* Generate your SSL cert or use the one during install

* Once the cert is generated, move it to /usr/share/rhn/ on server(so you remember where it is)

* copy the cert over to the client under /usr/share/rhn

* edit /etc/sysconfig/rhn/up2date on client and include sslCACert=/usr/share/rhn/<your-cert> and serverUrl= <your-spacewalk>

* re-register and retry

This should enable the client to look for the cert in the right place. If you still have issues, please reopen the bug.

~ Prad

Note You need to log in before you can comment on or make changes to this bug.