Bug 463969 - [RHEL5.3][Kernel Kernel BUG at lib/iomap.c:55
[RHEL5.3][Kernel Kernel BUG at lib/iomap.c:55
Status: CLOSED DUPLICATE of bug 463716
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
medium Severity high
: rc
: ---
Assigned To: David Milburn
Brock Organ
http://rhts.redhat.com/cgi-bin/rhts/t...
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 14:11 EDT by Jeff Burke
Modified: 2008-09-29 18:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 18:14:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Burke 2008-09-25 14:11:24 EDT
Description of problem:
While running an install with RHEL5.3-Server-20080925.nightly  x86_64 on ibm-x3200m2-01.rhts.bos.redhat.com the system panics

Version-Release number of selected component (if applicable):
RHEL5.3-Server-20080925.nightly
2.6.18-116.el5

How reproducible:
unknown

Steps to Reproduce:
1. Run a RHTS reserve workflow using RHEL5.3-Server-20080925.nightly x86_64
using ibm-x3200m2-01.rhts.bos.redhat.com
  
Actual results:
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at lib/iomap.c:55
invalid opcode: 0000 [1] SMP 
last sysfs file: /class/scsi_host/host0/proc_name
CPU 0 
Modules linked in: ata_piix libata mptsas scsi_transport_sas mptscsih mptbase tg3 libphy uhci_hcd ehci_hcd iscsi_ibft iscsi_tcp libiscsi scsi_transport_iscsi sr_mod sd_mod scsi_mod ide_cd cdrom ipv6 xfrm_nalgo crypto_api squashfs pcspkr edd loop nfs nfs_acl fscache lockd sunrpc vfat fat cramfs
Pid: 567, comm: loader Not tainted 2.6.18-116.el5 #1
RIP: 0010:[<ffffffff8014d585>]  [<ffffffff8014d585>] ioread8+0x17/0x2f
RSP: 0018:ffff81001ea1bc10  EFLAGS: 00010087
RAX: 0000000000000000 RBX: ffff81001ea20000 RCX: 0000000000000016
RDX: ffffffff88332328 RSI: 0000000000000000 RDI: 0000000000000000
RBP: ffff81001ea20000 R08: 40ff81001f2a9718 R09: 0000000000000040
R10: 00000000000000fa R11: ffffffff80217bbb R12: 0000000000000000
R13: 0000000000000000 R14: 0000000000000001 R15: 0000000000000000
FS:  000000001915e8b0(0063) GS:ffffffff803b8000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 00000000008386c8 CR3: 000000001e853000 CR4: 00000000000006e0
Process loader (pid: 567, threadinfo ffff81001ea1a000, task ffff81001efb5100)
Stack:  ffffffff88307330 0000000000000001 ffffffff88307475 ffff81001ea20000
 ffffffff88302c82 0000000000000282 ffffffff88302e80 0000000000000016
 ffff81001ea20000 ffff81001e867758 ffffffff882f9eb9 ffff81001fcdfc00
Call Trace:
 [<ffffffff88307330>] :libata:ata_sff_check_status+0x10/0x16
 [<ffffffff88307475>] :libata:ata_sff_freeze+0x3a/0x4c
 [<ffffffff88302c82>] :libata:__ata_port_freeze+0x52/0x58
 [<ffffffff88302e80>] :libata:ata_eh_freeze_port+0x2b/0x40
 [<ffffffff882f9eb9>] :libata:ata_host_start+0x10f/0x169
 [<ffffffff883068a6>] :libata:ata_pci_sff_activate_host+0x32/0x1c3
 [<ffffffff88309335>] :libata:ata_sff_interrupt+0x0/0x1c7
 [<ffffffff802177ce>] pcibios_set_master+0x80/0x85
 [<ffffffff8832dcd4>] :ata_piix:piix_init_one+0x66a/0x695
 [<ffffffff80155b50>] pci_device_probe+0x104/0x184
 [<ffffffff801b758c>] driver_probe_device+0x52/0xaa
 [<ffffffff801b76bb>] __driver_attach+0x65/0xb6
 [<ffffffff801b7656>] __driver_attach+0x0/0xb6
 [<ffffffff801b6ed5>] bus_for_each_dev+0x43/0x6e
 [<ffffffff801b6b1b>] bus_add_driver+0x7e/0x130
 [<ffffffff80155d28>] __pci_register_driver+0x4b/0x6c
 [<ffffffff8833c017>] :ata_piix:piix_init+0x17/0x28
 [<ffffffff800a4d15>] sys_init_module+0xaf/0x1e8
 [<ffffffff8005d116>] system_call+0x7e/0x83


Code: 0f 0b 68 2f b7 2a 80 c2 37 00 0f b7 d7 ec 0f b6 c0 c3 8a 07 
RIP  [<ffffffff8014d585>] ioread8+0x17/0x2f
 RSP <ffff81001ea1bc10>
 <0>Kernel panic - not syncing: Fatal exception

Expected results:
This should install

Additional info:
Comment 1 David Milburn 2008-09-25 15:34:57 EDT
Jeff,

This looks BZ 463716, stack trace is identical, it only occurs if we configure
the sata controller in IDE mode instead of AHCI mode. Is it possible that
the sata controller on this system is configured in IDE mode?
Comment 2 Jeff Burke 2008-09-29 18:00:26 EDT
David,
    Absolutely that could be the case. I wouldn't be surprised if we have some systems in RHTS set like that on purpose to catch these kinds of things. The only way I would know for sure is to actually go through the BIOS and take a look.

    Is there any way to tell from the boot log?
http://rhts.redhat.com/testlogs/30842/111282/946920/boot.messages
If not let me know I will go through the BIOS.
Comment 3 David Milburn 2008-09-29 18:14:47 EDT
Thanks Jeff, boot log confirms it is the same problem as BZ 463716 so I will mark
this as a duplicate.

*** This bug has been marked as a duplicate of bug 463716 ***

Note You need to log in before you can comment on or make changes to this bug.