Bug 463991 - Need support for berkeley db 4.7
Need support for berkeley db 4.7
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Database - General (Show other bugs)
1.1.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: FDS1.1.4 FDS1.2.0
  Show dependency treegraph
 
Reported: 2008-09-25 15:30 EDT by Rich Megginson
Modified: 2015-12-07 11:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:36:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for f-10 rawhide (6.37 KB, patch)
2008-09-29 16:58 EDT, Rich Megginson
no flags Details | Diff

  None (edit)
Description Rich Megginson 2008-09-25 15:30:07 EDT
The server fails to build with bdb 4.7:
ldap/servers/slapd/back-ldbm/dblayer.c: In function 'deadlock_threadmain':
ldap/servers/slapd/back-ldbm/dblayer.c:3452: error: 'DB_ENV' has no member named 'lk_handle'
ldap/servers/slapd/back-ldbm/dblayer.c: In function 'checkpoint_threadmain':
ldap/servers/slapd/back-ldbm/dblayer.c:3622: error: 'DB_ENV' has no member named 'tx_handle'
ldap/servers/slapd/back-ldbm/dblayer.c: In function 'trickle_threadmain':
ldap/servers/slapd/back-ldbm/dblayer.c:3780: error: 'DB_ENV' has no member named 'mp_handle'

Fedora 10 uses bdb 4.7.  Fedora DS fails to build on Fedora 10.
Comment 1 Rich Megginson 2008-09-29 16:58:39 EDT
Created attachment 318000 [details]
patch for f-10 rawhide

Proposed patch for F-10 rawhide
Comment 2 Jenny Galipeau 2009-03-30 16:17:10 EDT
I don't think QE can verify this with RH DS.
Comment 3 Rich Megginson 2009-03-30 16:42:19 EDT
This bug should not block DS 8.1.
Comment 5 Rich Megginson 2011-06-22 10:27:21 EDT
Since 389-ds-base works on RHEL6 which uses db4 version 4.7, you can mark this as VERIFIED.
Comment 6 Amita Sharma 2011-06-23 02:55:35 EDT
Thanks Rich.

Note You need to log in before you can comment on or make changes to this bug.