This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 464003 - Authentication fails when verifying a new windows printer connection
Authentication fails when verifying a new windows printer connection
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 16:13 EDT by Bruno Wolff III
Modified: 2008-10-15 17:08 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.8-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-15 13:11:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
script output (25.34 KB, application/octet-stream)
2008-09-26 13:37 EDT, Bruno Wolff III
no flags Details
Debug Output (21.55 KB, text/plain)
2008-10-11 14:36 EDT, Jason Taylor
no flags Details

  None (edit)
Description Bruno Wolff III 2008-09-25 16:13:39 EDT
Description of problem:
When setting a a new printer using smb to connect to a remote windows printer, entering credentials after hitting the verify button doesn't work ("You must login to access " print server name). However if instead of selecting "Prompt if user if authentication is required" I select "Set authentication details now" than things work.

Version-Release number of selected component (if applicable):
system-config-printer-1.0.7-2.fc10.x86_64

How reproducible:
I was only able to try it with one print server, but it happened all of the time with that one.

Steps to Reproduce:
1. Try to set up a new windows computer choosing to authenticate if needed after hitting "verify".
2.
3.
  
Actual results:
Authentication fails.

Expected results:
Authentication succeeds.

Additional info:
Comment 1 Tim Waugh 2008-09-26 04:29:07 EDT
Please expand on what you mean by this.  It is expected that you get an authentication dialog when verifying a queue for which 'Prompt user if authentication is required' is selected.

Is it that you are presented with this dialog after entering the correct details?

Please run 'system-config-printer --debug' from a terminal window and go through to the point where the authentication dialog is shown a second time, and attach the command line output here.
Comment 2 Bruno Wolff III 2008-09-26 11:33:17 EDT
Yes the dialog is presented, but my credentials don't work. The form is different than the one where you enter them before the verify, so it's possible I am doing something stupid, but I tried a couple of obvious varients and neither of them worked. The domain name for the account is 'ad'. So in the preverification form I enter my login as ad\bruno . In the verification form I tried both using 'bruno' as the login and 'ad' as the domain and leaving the domain prompt blank and using ad\bruno as the login. I used the same password in all cases.
I can't test the --debug option right now, but should be able to in a couple of hours.
Comment 3 Bruno Wolff III 2008-09-26 13:37:06 EDT
Created attachment 317816 [details]
script output

I tried twice getting prompt for credentials and used 'bruno' and 'ad' for the first test and 'ad\bruno' and '' for the second. Then I provided credentials before doing the verify using 'ad\bruno' and that succeeded.
Comment 5 Jason Taylor 2008-10-11 14:37:18 EDT
This is a problem with system-config-printer-1.0.8-2.fc10.x86_64.

Machine Information: Fresh install of rawhide (11-Oct-2008) x86_64.

Description:

Attempting to add a new printer provided by a Samba share from a CentOS 5.2 server fails. (The share functions and authentication works properly on other machines (Windows and Fedora 9) so that has been ruled out as a possible problem.) 

When browsing for the printer, the printer is found. When attempting to verify the connection to the printer with the Authentication left on "Prompt user if authentication is required" the verification fails. The Authentication window pops up with the Username, Domain and Password fields. With the fields filled out correctly (domain is set to the workgroup name) and after clicking "OK" the windows continues to prompt for authentication. 

After it failed with the workgroup name in the Domain field, I tried leaving the Domain field blank but I still get prompted for authentication.

If I change the Authentication radio buttion to "Set authentication details now" and use the same username/password combination as attempted prior the verification works flawlessly and consequent test pages were successful.

I have attached the debug output as well.
Comment 6 Tim Waugh 2008-10-15 13:11:08 EDT
Should be fixed now.  Thanks for helping debug it.
Comment 7 Bruno Wolff III 2008-10-15 17:08:31 EDT
FYI I tested this and it is fixed. But there is another problem I noticed stay tuned for a new bugzilla entry.

Note You need to log in before you can comment on or make changes to this bug.