Bug 464023 - DQ35JO system hangs when using intel driver in xorg.conf on -116.el5 kernel
DQ35JO system hangs when using intel driver in xorg.conf on -116.el5 kernel
Status: CLOSED DUPLICATE of bug 463853
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-i810 (Show other bugs)
5.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Regression
: 463954 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 18:14 EDT by Gary Case
Modified: 2008-10-24 16:13 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-06 18:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg configuration file (576 bytes, text/plain)
2008-10-01 13:44 EDT, Gary Case
no flags Details
xorg logfile from startx with no xorg.conf (29.86 KB, text/plain)
2008-10-01 13:44 EDT, Gary Case
no flags Details
xorg logfile from startx with intel driver in config file (29.86 KB, text/plain)
2008-10-01 13:45 EDT, Gary Case
no flags Details

  None (edit)
Description Gary Case 2008-09-25 18:14:07 EDT
Description of problem:
DQ35JO-based systems will hang on startx if the intel driver is used on the -116.el5 kernel. This problem previously happened under a specific set of conditions (and when using the xen kernel) but this is the first time it has happened under the bare metal kernel. The other problem is referenced here:

https://bugzilla.redhat.com/show_bug.cgi?id=412691

The system will automatically use the intel driver, even when you run system-config-display --reconfig. 

Version-Release number of selected component (if applicable):
Kernels 116.el5, 115.el5 are affected, kernel 109.el5 is not.

How reproducible:
Every time

Steps to Reproduce:
1. Install -116.el5 kernel
2. reboot
3. startx
  
Actual results:
Hung system

Expected results:
Functional system

Additional info:
Changing to the vesa driver prevents the problem.
Comment 1 Gary Case 2008-09-30 18:02:59 EDT
Problem still present in the 117 kernel.
Comment 2 Matěj Cepl 2008-10-01 04:22:45 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 3 Gary Case 2008-10-01 13:42:04 EDT
I've tried running without any xorg.conf file and the system still hangs. It even hangs on system-config-display --reconfig.

I just discovered that the system _always_ hangs under the -117.el5 kernel when I startx, regardless of whether I use the vesa or intel video drivers in my xorg.conf file.

I reverted to the -109.el5 kernel as a control and both drivers worked.
Comment 4 Gary Case 2008-10-01 13:44:07 EDT
Created attachment 319137 [details]
xorg configuration file
Comment 5 Gary Case 2008-10-01 13:44:44 EDT
Created attachment 319138 [details]
xorg logfile from startx with no xorg.conf
Comment 6 Gary Case 2008-10-01 13:45:30 EDT
Created attachment 319140 [details]
xorg logfile from startx with intel driver in config file
Comment 10 Cameron Meadors 2008-10-02 14:05:37 EDT
I get a hang on X shutdown with x86_64 kernel.  It does not hang when start X. 
Reproducing on same model motherboard.  I tried i386 and PAE kernel and I
cannot reproduce this. So it is only x86_64 as reported.
Comment 12 Gary Case 2008-10-02 15:37:27 EDT
I get a hang when I begin the installation on x86_64 from the latest beta tree. This worked just fine under 5.2.
Comment 13 Gary Case 2008-10-02 15:52:31 EDT
The hang occurs when X starts at the beginning of the install process. It's x86_64 only.
Comment 14 Dave Airlie 2008-10-06 18:16:42 EDT

*** This bug has been marked as a duplicate of bug 463853 ***
Comment 15 Dave Airlie 2008-10-20 18:14:00 EDT
*** Bug 463954 has been marked as a duplicate of this bug. ***
Comment 16 Robert M Williams 2008-10-24 16:13:21 EDT
adding the vga=791 option either at boot (pre-install) or in grub (post-install) fixes the issue I was having

Note You need to log in before you can comment on or make changes to this bug.