Bug 464052 - fix configure script failure on sh arch.
fix configure script failure on sh arch.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdf5 (Show other bugs)
rawhide
sh4 Linux
medium Severity medium
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 23:31 EDT by CHIKAMA Masaki
Modified: 2008-09-26 17:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 17:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hdf-filter_asoption.patch (507 bytes, patch)
2008-09-25 23:31 EDT, CHIKAMA Masaki
no flags Details | Diff

  None (edit)
Description CHIKAMA Masaki 2008-09-25 23:31:50 EDT
Created attachment 317760 [details]
hdf-filter_asoption.patch

Description of problem:

 This patch enables to compile hdf5 on sh architecture.
On this arch, gcc(gfortran) passes "-little" option to gas 
when compiling for backward compatibility. 
The configure script fails because of it.
I also sent a patch for autoconf package beacuse
this configure script was generated by autoconf.
(see Bug #456886)

--- hdf5-1.8.0/configure.org    2008-07-22 18:44:12.000000000 +0900
+++ hdf5-1.8.0/configure        2008-07-22 18:44:42.000000000 +0900
@@ -4909,7 +4909,7 @@
                                                                                
           ;;
           # Ignore these flags.
-        -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | LIST:* | -LNO:*)
+        -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | LANG:=* | -LIST:* | -LNO:*)
           ;;
         -lkernel32)
           test x"$CYGWIN" != xyes && ac_cv_fc_libs="$ac_cv_fc_libs $ac_arg"


Version-Release number of selected component (if applicable):
hdf5-1.8.1-1
Comment 1 Orion Poplawski 2008-09-26 17:25:03 EDT
Fixed with 1.8.1-2.fc10.

Note You need to log in before you can comment on or make changes to this bug.