Bug 464055 - fix configure script failure on sh arch.
fix configure script failure on sh arch.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: R (Show other bugs)
rawhide
sh4 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 23:38 EDT by CHIKAMA Masaki
Modified: 2008-10-16 16:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-16 16:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
R-2.7.2-filter_asoption.patch (505 bytes, patch)
2008-09-25 23:38 EDT, CHIKAMA Masaki
no flags Details | Diff

  None (edit)
Description CHIKAMA Masaki 2008-09-25 23:38:32 EDT
Created attachment 317761 [details]
R-2.7.2-filter_asoption.patch

Description of problem:

 This patch enables to compile R on sh architecture.
On this arch, gcc(gfortran) passes "-little" option to gas 
when compiling for backward compatibility. 
The configure script fails because of it.
I also sent a patch for autoconf package beacuse
this configure script was generated by autoconf.
(see Bug #456886)

--- R-2.7.2/configure.org       2008-09-25 15:00:20.000000000 +0900
+++ R-2.7.2/configure   2008-09-25 15:00:35.000000000 +0900
@@ -26995,7 +26995,7 @@
                                                                                
           ;;
           # Ignore these flags.
-        -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | LIST:* | -LNO:*)
+        -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | LANG:=* | -LIST:* | -LNO:*)
           ;;
         -lkernel32)
           test x"$CYGWIN" != xyes && ac_cv_f77_libs="$ac_cv_f77_libs $ac_arg"


Version-Release number of selected component (if applicable):
 R-2.7.2-1
Comment 1 CHIKAMA Masaki 2008-09-25 23:40:32 EDT
Also need this patch to R.spec. Please apply.

--- R.spec.org  2008-09-25 14:56:54.000000000 +0900
+++ R.spec      2008-09-25 15:01:49.000000000 +0900
@@ -137,7 +139,7 @@
           export F77="gfortran -m64"
           export FC="gfortran -m64"
       ;;
-      ia64|alpha)
+      ia64|alpha|sh*)
           export CC="gcc"
           export CXX="g++"
           export F77="gfortran"
Comment 2 Tom "spot" Callaway 2008-10-16 16:45:43 EDT
Fixes committed to rawhide and mailed to upstream for inclusion, closing out.

Note You need to log in before you can comment on or make changes to this bug.