Bug 464082 - Thunderbird crashes when using Esc key to close the 'Attach Files' window twice [NEEDINFO]
Thunderbird crashes when using Esc key to close the 'Attach Files' window twice
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 04:06 EDT by lihuang
Modified: 2014-06-03 08:49 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-03 08:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (lihuang)


Attachments (Terms of Use)
backtrace (12.77 KB, text/plain)
2008-09-26 04:06 EDT, lihuang
no flags Details
new backtrace (33.70 KB, text/plain)
2008-10-05 03:32 EDT, lihuang
no flags Details

  None (edit)
Description lihuang 2008-09-26 04:06:37 EDT
Created attachment 317776 [details]
backtrace

Description of problem:
Thunderbird crashes when using Esc key to close the 'Attach Files' window twice

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.17-1.el5
thunderbird-debuginfo-2.0.0.17-1.el5




How reproducible:
Everytime


Steps to Reproduce:
1.Launch thunderbird, Open a compose window.
2.Click the 'Attach' tool on toolbar.
3.Press 'Esc' key to close the pup up window
4.Repeat step2,3  (sometimes need repeat more )
  
Actual results:
thunderbirder crashed,

[lihuang@dhcp-65-158 ~]$ thunderbird 
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
The messenger is now down
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
The messenger is now down
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
The messenger is now down
Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
/usr/lib/thunderbird-2.0.0.17/run-mozilla.sh: line 131: 14915 Segmentation fault      (core dumped) "$prog" ${1+"$@"}

Expected results:


Additional info:
as the error message mention scim. the following is scim package's info:
scim-1.4.4-39.el5
scim-bridge-gtk-0.4.5-7.el5
scim-pinyin-0.5.91-16.el5
scim-libs-1.4.4-39.el5
scim-tables-0.5.6-7
scim-anthy-1.2.0-6.el5
scim-m17n-0.2.0-6.fc6
scim-qtimm-0.9.4-5
scim-sinhala-0.2.0-2.fc6
scim-chewing-0.3.1-11.el5
scim-chinese-standard-0.0.2-1.el5
scim-bridge-0.4.5-7.el5
scim-tables-chinese-0.5.6-7
scim-hangul-0.2.2-7.fc6
Comment 1 Lawrence Lim 2008-09-27 23:18:37 EDT
Is this a regression?
Comment 2 RHEL Product and Program Management 2008-09-27 23:22:26 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 lihuang 2008-09-28 00:53:05 EDT
test on x86_64 arch
thunderbird didn't crash .
but the error msg also outputted :

Failed to receive messages at scim_bridge_client_read_and_dispatch ()
An IOException at scim_bridge_client_change_focus ()
An IOException occurred at scim_bridge_client_imcontext_focus_out ()
An IOException occurred at scim_bridge_client_imcontext_set_cursor_location ()
The imcontext has already been registered
Cannot register the IMContexts...



package's info:
$ rpm -qa scim* thunderbird*
scim-m17n-0.2.0-6.fc6
scim-qtimm-0.9.4-5
scim-bridge-0.4.5-7.el5
scim-qtimm-0.9.4-5
thunderbird-2.0.0.17-1.el5
scim-tables-0.5.6-7
scim-sinhala-0.2.0-2.fc6
scim-1.4.4-39.el5
scim-anthy-1.2.0-6.el5
scim-chinese-standard-0.0.2-1.el5
scim-libs-1.4.4-39.el5
scim-bridge-gtk-0.4.5-7.el5
scim-pinyin-0.5.91-16.el5
scim-libs-1.4.4-39.el5
scim-hangul-0.2.2-7.fc6
scim-tables-chinese-0.5.6-7
thunderbird-debuginfo-2.0.0.17-1.el5
scim-chewing-0.3.1-11.el5
scim-bridge-gtk-0.4.5-7.el5
Comment 4 lihuang 2008-09-28 01:03:16 EDT
also test the case with other packages, the following list shows which would crash and which not


crash:
thunderbird-2.0.0.14-1.el5_2  (i386)
thunderbird-2.0.0.17-1.el5    (i386)


not crash ( IOException error msg always be outputted )
thunderbird-1.5.0.9-6.el5   (i386)
thunderbird-2.0.0.17-1.el5  (x86_64)
thunderbird-2.0.0.14-1.fc9  (i386)
thunderbird-2.0.0.14-1.fc10  (i386)
thunderbird-2.0.0.16-1.fc10  (i386)
Comment 5 Martin Stransky 2008-10-02 03:05:57 EDT
The crash comes from glib2 (a part of GTK). Please install glib2-debuginfo and all available GTK+ & scim debuginfo packages and attach the backtrace again.
Comment 6 Martin Stransky 2008-10-02 03:06:53 EDT
Don't forget to install pango & cairo debuginfo packages, too. thanks.
Comment 8 lihuang 2008-10-05 03:32:17 EDT
Created attachment 319490 [details]
new backtrace

lihuang -> Martin & Lawrence

Here is the new bt file.
Comment 9 Christopher Aillon 2009-03-10 18:59:36 EDT
Seems to be crashing in gtk widget code called from the file chooser.  Sending to gtk2 for further triaging...
Comment 10 RHEL Product and Program Management 2009-03-26 12:55:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 13 RHEL Product and Program Management 2014-03-07 08:57:03 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 14 RHEL Product and Program Management 2014-06-03 08:49:42 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.