Bug 464098 - compiled against db 4.7, linked against db 4.3
compiled against db 4.7, linked against db 4.3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 463790
  Show dependency treegraph
 
Reported: 2008-09-26 05:23 EDT by Dan Horák
Modified: 2008-09-26 07:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: cyrus-sasl-2.1.22-19.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-26 07:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add support for newer version of db4 (1.51 KB, patch)
2008-09-26 05:23 EDT, Dan Horák
no flags Details | Diff
patch for the spec file (1.50 KB, patch)
2008-09-26 05:29 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description Dan Horák 2008-09-26 05:23:24 EDT
Created attachment 317778 [details]
add support for newer version of db4

+++ This bug was initially created as a clone of Bug #461875 +++

berkdb.m4 in the cyrus-imapd sources needs to be fixed to look for db 4.7.  Otherwise, when it's built against current rawhide, it uses db 4.7 header files but links against older db libraries and won't run.



The situation in cyrus-sasl is the same, only with the difference that it is linked against libdb-4.3, which is the last version mentioned in cmulocal/berkdb.m4
Comment 1 Dan Horák 2008-09-26 05:29:51 EDT
Created attachment 317779 [details]
patch for the spec file
Comment 2 Tomas Mraz 2008-09-26 07:07:26 EDT
Fixed. Thanks for the report. I've made the patch more general by just moving db in front of the rest.

Note You need to log in before you can comment on or make changes to this bug.