Bug 464101 - "Evdev-managed keyboard" - as default value for keyboard model in keyboard layout
"Evdev-managed keyboard" - as default value for keyboard model in keyboard la...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 05:56 EDT by Michal Hlavinka
Modified: 2008-09-29 08:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.0-28.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 08:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2008-09-26 05:56:14 EDT
Description of problem:
In KDE - system settings - Regional & Language - Keyboard layout - keyboard model combobox : "Evdev-managed keyboard" should be selected as default value, because it's only value working with new xorg server using evdev (at least with usb keyboard, not tested with a ps/2 keyboard).




Version-Release number of selected component (if applicable):
Fedora 10 Beta
kdebase-workspace-4.1.1-2.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1.In system settings - Regional & Language - Keyboard layout
2.Create keyboard layouts "as usual" (just add desired layouts)
3.
  
Actual results:
Keyboard stops working (arrows, home/end/...)

Expected results:
Keyboard works

Additional info:
Not tested with ps/2 keyboard, but AFAIK no usb keyboard (includes some laptops) works with setxkbmap -model something_else_then_evdev ... 

https://fedoraproject.org/wiki/Features/EvdevInputDriver
Comment 1 Kevin Kofler 2008-09-26 06:04:26 EDT
See also this ML thread:
https://www.redhat.com/archives/fedora-test-list/2008-September/msg00475.html

Rex, something for kde-settings?
Comment 2 Michal Hlavinka 2008-09-26 06:13:59 EDT
(In reply to comment #1)
In F9 there was the same problem for some time, but update of xorg-x11-server to 1.5.0-2.fc9 (with xserver-1.5.0-no-evdev-keyboards-kthnx.patch) should be fixing this (at least for me - in F9 -model pc104 (and others) is working, but -model evdev stopped working).

Evdev driver in F10 stays and works (see feature wiki in description)
Comment 3 Kevin Kofler 2008-09-27 05:22:21 EDT
Should be fixed in kde-settings-4.0-28.fc10 which is now building and should hit Rawhide once it unfreezes after the beta.
Comment 5 Kevin Kofler 2008-09-29 08:50:06 EDT
Should be fixed in Rawhide now, please reopen if this is still an issue with the current kde-settings.

Note You need to log in before you can comment on or make changes to this bug.