Bug 464104 - hal shouldn't poll for non existent CD drives
hal shouldn't poll for non existent CD drives
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11PowerSaving FedoraMini/Mobility
  Show dependency treegraph
 
Reported: 2008-09-26 06:23 EDT by Peter Robinson
Modified: 2010-01-12 18:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 18:05:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2008-09-26 06:23:26 EDT
All the netbook style devices such as the eeePC don't come with CD drives, nor do a lot of the sub notebooks such as the MacBook Air. According to powertool running on my eeePC 901 with current rawhide hal is still polling /dev/scd0 even though it will never exisit. HAL should detect if there's a CD to poll and if there isn't it shouldn't try to poll it.
Comment 1 Bastien Nocera 2008-09-30 11:04:52 EDT
I'm pretty sure powertop's warning is bogus. You'd see something like this in the process list if CD drives/floppy drives were present:
root      2106  0.0  0.0  24192   928 ?        S    Sep26   0:17 hald-addon-storage: polling /dev/sr0 (every 2 sec)
root      2115  0.0  0.0  24192   924 ?        S    Sep26   0:00 hald-addon-storage: no polling on /dev/fd0 because it is explicitly disabled

This doesn't happen on my Dell Latitude D420 which doesn't have a builtin CD drive, or floppy drive either.
Comment 2 Peter Robinson 2008-10-01 17:07:06 EDT
On the F-10 beta + todays rawhide updates on the eeePC 901 I get the following so it seems that it is polling as reported by powertop

[root@trinity ~]# ps -aux | grep hal
Warning: bad syntax, perhaps a bogus '-'? See /usr/share/doc/procps-3.2.7/FAQ
68        2101  0.0  0.4   6448  4156 ?        Ss   09:38   0:17 hald
root      2167  0.0  0.0   3548   988 ?        S    09:38   0:00 hald-runner
root      2201  0.0  0.0   3624   932 ?        S    09:38   0:00 hald-addon-input: Listening on /dev/input/event0 /dev/input/event8 /dev/input/event3 /dev/input/event1 /dev/input/event2 /dev/input/event5 /dev/input/event7
root      2207  0.0  0.0   3632   892 ?        S    09:38   0:00 /usr/libexec/hald-addon-cpufreq
68        2208  0.0  0.0   2276   872 ?        S    09:38   0:00 hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
peter     3058  0.0  0.2  17212  2812 ?        Sl   09:40   0:00 /usr/libexec/gvfs-hal-volume-monitor
root      4075  0.0  0.0   4184   708 pts/0    S+   22:03   0:00 grep hal
root     16732  0.0  0.0   3628   924 ?        S    20:55   0:01 hald-addon-storage: polling /dev/sdc (every 2 sec)
Comment 3 Bastien Nocera 2008-10-01 18:55:50 EDT
What's /dev/sdc on your system?
Comment 4 Peter Robinson 2008-10-01 19:23:09 EDT
Its the SDHC slot. There's a 4gig SSD for /dev/sda, 16gig SSD for /dev/sdb and the SD slot for /dev/sdc which currently has a 8gig SDHC card in it.
Comment 5 Bug Zapper 2008-11-25 22:13:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Dominik 'Rathann' Mierzejewski 2009-02-16 17:29:05 EST
(In reply to comment #4)
> Its the SDHC slot. There's a 4gig SSD for /dev/sda, 16gig SSD for /dev/sdb and
> the SD slot for /dev/sdc which currently has a 8gig SDHC card in it.

Well, the SDHC slot is a "removable device", so it should be polled.
Comment 7 Peter Robinson 2009-02-17 04:25:01 EST
> > Its the SDHC slot. There's a 4gig SSD for /dev/sda, 16gig SSD for /dev/sdb and
> > the SD slot for /dev/sdc which currently has a 8gig SDHC card in it.
> 
> Well, the SDHC slot is a "removable device", so it should be polled.

I thought removable devices were only polled if they didn't give appropriate "Media inserted" and "Media removed" calls to indicate whether media appears or disappears and hence had to be polled to see whether media appears or goes away, if they do provide that instance like SD card slots do and hence they don't need to be polled.
Comment 8 Scott Glaser 2009-04-10 19:03:14 EDT
Peter,

Have you updated your Fedora 10 installation or tried Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Peter Robinson 2009-04-26 07:19:28 EDT
With current rawhide powertop still reports that hal is polling a removable device.
Comment 10 Peter Robinson 2009-06-06 07:14:45 EDT
On my eeePC on the latest F-11 update I still get powertop reporting hal polling cd drives. Doing a ps shows the following. I thought this had moved to DeviceKit-disks for F-11?

[peter@localhost ~]$ ps xa | grep hal
 1378 ?        Ss     8:08 hald
 1382 ?        S      0:00 hald-runner
 1473 ?        S      0:00 hald-addon-input: Listening on /dev/input/event8 /dev/input/event2 /dev/input/event3 /dev/input/event6 /dev/input/event0 /dev/input/event1 /dev/input/event5
 1474 ?        S      1:02 /usr/libexec/hald-addon-rfkill-killswitch
 1492 ?        S      0:00 /usr/libexec/hald-addon-generic-backlight
 1507 ?        S      0:00 /usr/libexec/hald-addon-cpufreq
 1508 ?        S      0:00 hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
 1509 ?        S      0:01 hald-addon-storage: polling /dev/sdc (every 2 sec)
23641 pts/1    S+     0:00 grep hal
[peter@localhost ~]$
Comment 11 Scott Glaser 2009-09-09 08:05:46 EDT
Have you tried with the latest hal package in Fedora 11 or tried Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Peter Robinson 2009-09-09 08:08:50 EDT
Yes. This is on rawhide (up to date as of yesterday):

[peter@trinity ~]$ ps xa| grep hal
  698 ?        Ss     1:16 hald
  702 ?        S      0:00 hald-runner
  804 ?        S      0:00 hald-addon-input: Listening on /dev/input/event8 /dev/input/event2 /dev/input/event3 /dev/input/event7 /dev/input/event0 /dev/input/event1 /dev/input/event5
  805 ?        S      0:00 /usr/libexec/hald-addon-rfkill-killswitch
  818 ?        S      0:00 /usr/libexec/hald-addon-generic-backlight
  821 ?        S      0:00 hald-addon-acpi: listening on acpi kernel interface /proc/acpi/event
  823 ?        S      0:32 hald-addon-storage: polling /dev/sdc (every 2 sec)
 6562 pts/1    S+     0:00 grep hal
Comment 13 Bug Zapper 2009-11-16 04:27:37 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Peter Robinson 2010-01-12 18:05:50 EST
It seems this is fixed in the 0.5.14 release as I don't see hald-addon-storage running any more

Note You need to log in before you can comment on or make changes to this bug.