Bug 464133 - can't access translate.fp.o
can't access translate.fp.o
Status: CLOSED NEXTRELEASE
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Domingo Becker
Diego Búrigo Zacarão
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 09:01 EDT by Domingo Becker
Modified: 2008-10-03 18:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-03 18:04:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Domingo Becker 2008-09-26 09:01:04 EDT
Description of problem:
I can't access DL page to download po files.
http://translate.fedoraproject.org/languages/es/fedora-10


Version-Release number of selected component (if applicable):


How reproducible:
Follow this link:
http://translate.fedoraproject.org/languages/es/fedora-10

Steps to Reproduce:
1.
2.
3.
  
Actual results:
KeyError	Python 2.4.3: /usr/bin/python
Fri Sep 26 12:56:02 2008

A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
...

Expected results:


Additional info:
Comment 1 Piotr Drąg 2008-09-30 07:23:29 EDT
Strange. Works for me just perfectly.
Comment 2 Piotr Drąg 2008-09-30 07:25:41 EDT
Hm... It seems that it works randomly. Needs to be investigated by Python programmers.
Comment 3 Domingo Becker 2008-09-30 07:39:10 EDT
I'm using Fedora 9 and this is the page I get in firefox:

 --> -->
 
 
KeyError	Python 2.4.3: /usr/bin/python
Tue Sep 30 11:36:30 2008

A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
 /srv/web/translation/teams.py
  263                     html.team['bugzilla-component'] = html.language_name + " [%s]" % (langid)
  264 
  265                 print unicode(html).encode('utf-8')
  266                 if t_ext != '.xml':
  267                     print utils.TemplateInspector(html)
builtin unicode = <type 'unicode'>, html = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, ).encode undefined
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in __str__(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>)
  980             mainMethName = getattr(concreteTemplateClass,mainMethNameAttr, None)
  981             if mainMethName:
  982                 def __str__(self): return getattr(self, mainMethName)()
  983             elif (hasattr(concreteTemplateClass, 'respond')
  984                   and concreteTemplateClass.respond!=Servlet.respond):
__str__ undefined, self = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, builtin getattr = <built-in function getattr>, mainMethName = 'respond'
 /srv/web/translation/DynamicallyCompiledCheetahTemplate.py in respond(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in _handleCheetahInclude(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, srcArg='templates/language-release-ui-stats.tmpl', trans=<Cheetah.DummyTransaction.DummyTransaction instance>, includeFrom='file', raw=False)
 1528         ##
 1529         if not raw:
 1530             self._CHEETAH__cheetahIncludes[_includeID].respond(trans)
 1531         else:
 1532             trans.response().write(self._CHEETAH__cheetahIncludes[_includeID])
self = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, self._CHEETAH__cheetahIncludes = {'templates/header.tmpl': <_srv_web_translation_templates_header_tmpl._srv_web_translation_templates_header_tmpl object>, 'templates/language-release-ui-stats.tmpl': <_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, 'templates/team-info.tmpl': <_srv_web_translation_templates_team_info_tmpl._srv_web_translation_templates_team_info_tmpl object>}, _includeID = 'templates/language-release-ui-stats.tmpl', ].respond undefined, trans = <Cheetah.DummyTransaction.DummyTransaction instance>
 /srv/web/translation/_srv_web_translation_templates_language_release_ui_stats_tmpl.py in respond(self=<_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in _handleCheetahInclude(self=<_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, srcArg='templates/language-release-ui-stats-modules.tmpl', trans=<Cheetah.DummyTransaction.DummyTransaction instance>, includeFrom='file', raw=False)
 1528         ##
 1529         if not raw:
 1530             self._CHEETAH__cheetahIncludes[_includeID].respond(trans)
 1531         else:
 1532             trans.response().write(self._CHEETAH__cheetahIncludes[_includeID])
self = <_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, self._CHEETAH__cheetahIncludes = {'templates/language-release-ui-stats-modules.tmpl': <_srv_web_translation_templates_language_release...es_language_release_ui_stats_modules_tmpl object>}, _includeID = 'templates/language-release-ui-stats-modules.tmpl', ].respond undefined, trans = <Cheetah.DummyTransaction.DummyTransaction instance>
 /srv/web/translation/_srv_web_translation_templates_language_release_ui_stats_modules_tmpl.py in respond(self=<_srv_web_translation_templates_language_release...es_language_release_ui_stats_modules_tmpl object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /srv/web/translation/l10n.py in filter(self=<l10n.MyFilter object>, val=u'%(m\xf3dulo/id)', **kw={})
   90                 del kw['CAPITALIZE']
   91             val = val.replace(u'%20', ' ')
   92             return val % kw
   93         else:
   94             return unicode(val)
val = u'%(m\xf3dulo/id)', kw = {}

KeyError: u'm\xf3dulo/id'
      args = (u'm\xf3dulo/id',)
Comment 4 Martin-Gomez Pablo 2008-09-30 13:54:03 EDT
I can comfirm the issue. I get the bug (quite different from Domingo's one) in Firefox as well as Opera (I've test with the /es/fedora-10 and /fr/fedora-10).*

Bug report :

 --> -->
 
 
TypeError	Python 2.4.3: /usr/bin/python
Tue Sep 30 17:33:01 2008

A problem occurred in a Python script. Here is the sequence of function calls leading up to the error, in the order they occurred.
 /srv/web/translation/teams.py
  263                     html.team['bugzilla-component'] = html.language_name + " [%s]" % (langid)
  264 
  265                 print unicode(html).encode('utf-8')
  266                 if t_ext != '.xml':
  267                     print utils.TemplateInspector(html)
builtin unicode = <type 'unicode'>, html = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, ).encode undefined
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in __str__(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>)
  980             mainMethName = getattr(concreteTemplateClass,mainMethNameAttr, None)
  981             if mainMethName:
  982                 def __str__(self): return getattr(self, mainMethName)()
  983             elif (hasattr(concreteTemplateClass, 'respond')
  984                   and concreteTemplateClass.respond!=Servlet.respond):
__str__ undefined, self = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, builtin getattr = <built-in function getattr>, mainMethName = 'respond'
 /srv/web/translation/DynamicallyCompiledCheetahTemplate.py in respond(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in _handleCheetahInclude(self=<DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, srcArg='templates/language-release-ui-stats.tmpl', trans=<Cheetah.DummyTransaction.DummyTransaction instance>, includeFrom='file', raw=False)
 1528         ##
 1529         if not raw:
 1530             self._CHEETAH__cheetahIncludes[_includeID].respond(trans)
 1531         else:
 1532             trans.response().write(self._CHEETAH__cheetahIncludes[_includeID])
self = <DynamicallyCompiledCheetahTemplate.DynamicallyCompiledCheetahTemplate object>, self._CHEETAH__cheetahIncludes = {'templates/header.tmpl': <_srv_web_translation_templates_header_tmpl._srv_web_translation_templates_header_tmpl object>, 'templates/language-release-ui-stats.tmpl': <_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, 'templates/team-info.tmpl': <_srv_web_translation_templates_team_info_tmpl._srv_web_translation_templates_team_info_tmpl object>}, _includeID = 'templates/language-release-ui-stats.tmpl', ].respond undefined, trans = <Cheetah.DummyTransaction.DummyTransaction instance>
 /srv/web/translation/_srv_web_translation_templates_language_release_ui_stats_tmpl.py in respond(self=<_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /usr/lib/python2.4/site-packages/Cheetah/Template.py in _handleCheetahInclude(self=<_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, srcArg='templates/language-release-ui-stats-modules.tmpl', trans=<Cheetah.DummyTransaction.DummyTransaction instance>, includeFrom='file', raw=False)
 1528         ##
 1529         if not raw:
 1530             self._CHEETAH__cheetahIncludes[_includeID].respond(trans)
 1531         else:
 1532             trans.response().write(self._CHEETAH__cheetahIncludes[_includeID])
self = <_srv_web_translation_templates_language_release..._templates_language_release_ui_stats_tmpl object>, self._CHEETAH__cheetahIncludes = {'templates/language-release-ui-stats-modules.tmpl': <_srv_web_translation_templates_language_release...es_language_release_ui_stats_modules_tmpl object>}, _includeID = 'templates/language-release-ui-stats-modules.tmpl', ].respond undefined, trans = <Cheetah.DummyTransaction.DummyTransaction instance>
 /srv/web/translation/_srv_web_translation_templates_language_release_ui_stats_modules_tmpl.py in respond(self=<_srv_web_translation_templates_language_release...es_language_release_ui_stats_modules_tmpl object>, trans=<Cheetah.DummyTransaction.DummyTransaction instance>)
 /srv/web/translation/l10n.py in filter(self=<l10n.MyFilter object>, val=u'Les fichiers suivants sont r\xe9f\xe9renc\xe9s soit dans ...</li>\n<li>msgstr "translator-credits"\n</li>\n</ul>', **kw={})
   90                 del kw['CAPITALIZE']
   91             val = val.replace(u'%20', ' ')
   92             return val % kw
   93         else:
   94             return unicode(val)
val = u'Les fichiers suivants sont r\xe9f\xe9renc\xe9s soit dans ...</li>\n<li>msgstr "translator-credits"\n</li>\n</ul>', kw = {}

TypeError: not enough arguments for format string
      args = ('not enough arguments for format string',)
Comment 5 Dimitris Glezos 2008-10-03 11:22:38 EDT
The problem is in es.po:

http://cvs.fedoraproject.org/viewvc/web/flpweb/po/es.po?revision=HEAD&root=l10n&view=markup

#: ../fedora-modules.xml.in.h:2
#, no-c-format
msgid "%(module/id)"
msgstr "%(módulo/id)"

Contents inside %() should not be translated. You can commit the fix and mark it as LIVE with:  `cvs tag -F LIVE po/es.po`, and in a few hours it should be fixed.

Please close the bug report once you see the problem fixed.

Note You need to log in before you can comment on or make changes to this bug.