Bug 464151 - About 1.0.0 build failure
About 1.0.0 build failure
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: deluge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 10:32 EDT by Mamoru TASAKA
Modified: 2008-09-28 01:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 01:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch candidate (951 bytes, patch)
2008-09-26 10:32 EDT, Mamoru TASAKA
no flags Details | Diff

  None (edit)
Description Mamoru TASAKA 2008-09-26 10:32:04 EDT
Created attachment 317799 [details]
patch candidate

Description of problem:
(Well, Is this issue being discussed on the upstream?)
http://koji.fedoraproject.org/koji/taskinfo?taskID=838268

The problem is:
* libboost_filesystem.so surely exists as well as libboost_filesystem-mt.so.
  libboost_filesystem.so is single thread version of boost filesystem
  library (they say) and actually differs (in size) from libboost_filesystem-mt.so.

  Only libboost_thread.so does not exist, because there is no "single thread"
  variant of boost "thread" library (see bug 250802). So current -mt check
  by deluge setup.py:
--------------------------------------------------------------
   147      # Modify the libs if necessary for systems with only -mt boost libs    
   148      if not os.path.exists(
   149          os.path.join(sysconfig.PREFIX, "lib", "libboost_filesystem.so")):
   150          # It's likely that this system doesn't have symlinks setup
   151          # So add '-mt' to the libraries
   152          for lib in _libraries:
   153              if lib[:6] == "boost_":
   154                  _libraries[_libraries.index(lib)] = lib + "-mt"
--------------------------------------------------------------
  fails.

  Note that this perhaps succeeds on x86_64, because "/usr/lib/libboost_filesystem.so"
  is not found on x86_64, however this is not what these line expects.

  So: a possible fix might be:
  * to change the file to be checked from "libboost_filesystem.so" to
    "libboost_thread.so"
  * and to support libdir (or LIBDIR) argument (or environment)

Version-Release number of selected component (if applicable):
deluge-1.0.0-1.fc10

Additional info:
Possible patch attached. Changing to
----------------------------------------------------------------
CFLAGS="%{optflags}" LIBDIR=%{_libdir} %{__python} setup.py build
----------------------------------------------------------------
with the attached patch will make the build succeed:
http://koji.fedoraproject.org/koji/taskinfo?taskID=845299
Comment 1 Peter Gordon 2008-09-27 16:46:19 EDT
I tried to commit and build it a few days ago but it failed with this issue of mt libs; and I didn't have time due to schoolwork and job stuff to look at it until the weekend. 

I'll take care of this after some food. Thank you very much for the patch! :)
Comment 2 Peter Gordon 2008-09-28 01:34:19 EDT
Committed and built to rawhide. Thanks again for the patch!

Note You need to log in before you can comment on or make changes to this bug.