Bug 464180 - [LTC 6.0 FEAT] 201719:Reipl support
[LTC 6.0 FEAT] 201719:Reipl support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All All
high Severity high
: alpha
: 6.0
Assigned To: Anaconda Maintenance Team
Release Test Team
: FutureFeature
: 533487 (view as bug list)
Depends On:
Blocks: 356741 554559
  Show dependency treegraph
 
Reported: 2008-09-26 11:30 EDT by IBM Bug Proxy
Modified: 2010-07-02 16:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: anaconda-12.38.1-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 16:39:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2008-09-26 11:30:30 EDT
=Comment: #0=================================================
Emily J. Ratliff <emilyr@us.ibm.com> - 2008-09-24 13:53 EDT
1. Feature Overview:
Feature Id:	[201719]
a. Name of Feature:	Reipl support
b. Feature Description
The Linux kernel already has support for a feature called Reipl.  We want to enable the installer to
use Reipl.  What Reipl does is instruct the 390 where to boot next.  This is different than a boot
loader since the 390 does not support a default boot location.    Also, this tool can be used by a
system administrator during other times.  If they want to shutdown the machine and reboot from a
different partition.    There are documentation hits on this as well.    Versions of hardware/software:
  - LPAR on machine older than z9
  - LPAR on z9 or newer (required to reipl from FCP)
  - z/VM 5.2 or older
  - z/VM 5.4 or later (required to reipl from FCP)

2. Feature Details:
Sponsor:	LTC
Architectures:
s390 native
s390 compat
s390x

Arch Specificity: Purely Arch Specific Code
Affects Installer: Yes
Delivery Mechanism: Backport
Category:	Installation
Request Type:	Installer - Enhancement from IBM
d. Upstream Acceptance:	Accepted
Sponsor Priority	2
f. Severity: Medium
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	The reipl code is included in the Linux mainline kernel and the distro
kernels that this feature has been targeted for.  The installer does not have an associated upstream
project, so IBM will provide code directly.

3. Business Case
Avoid customer frustration on installation by rebooting automatically instead of manually between
install phase 1 and 2.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Sarah Wright, sarahw@us.ibm.com, 503-578-5145

Technical contact(s):
Mark Hamzy, hamzy@us.ibm.com

IBM Manager:
Jeffrey Heroux, heroux@us.ibm.com
Comment 1 IBM Bug Proxy 2009-03-03 12:01:20 EST
This has been checked into rawhide.

commit d00ef216099104c03c400f56fb21e19089df4a7d
Author: Mark Hamzy <hamzy@us.ibm.com>
Date:   Mon Feb 16 14:19:35 2009 -0600

reIPL support for s390

Signed-off-by: David Cantrell <dcantrell@redhat.com>
Comment 2 IBM Bug Proxy 2009-03-03 13:50:55 EST
Can't really test this as the rawhide build on Z is not working yet.
Comment 3 John Jarvis 2009-10-15 10:58:31 EDT
IBM is signed up to test and provide feedback
Comment 5 releng-rhel@redhat.com 2009-11-10 17:39:07 EST
Fixed in 'anaconda-12.38.1-1'. 'anaconda-12.38.4-1.el6' included in compose 'RHEL6.0-20091110.0'.
Moving to ON_QA.
Comment 6 John Jarvis 2009-11-11 11:29:24 EST
*** Bug 533487 has been marked as a duplicate of this bug. ***
Comment 7 IBM Bug Proxy 2010-05-12 16:50:58 EDT
------- Comment From hamzy@us.ibm.com 2010-05-12 16:45 EDT-------
Tested with SNAP2 against T on both DASD and SCSI partitions.
Comment 8 Jan Stodola 2010-06-21 04:45:06 EDT
I can confirm this is working in z/VM 5.4 for both DASD and FCP LUN.
Tested on tree RHEL6.0-20100603.1 with anaconda-13.21.50-2.el6

Moving to VERIFIED
Comment 9 releng-rhel@redhat.com 2010-07-02 16:39:50 EDT
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.