Bug 464220 - /etc/crypttab is ignored
/etc/crypttab is ignored
Status: CLOSED DUPLICATE of bug 464216
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-09-26 15:08 EDT by Lennart Poettering
Modified: 2014-03-16 23:15 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 17:40:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2008-09-26 15:08:14 EDT
After updating to current Rawhide my boot was completely hosed. /etc/crypttab seems to be ignored now which caused mount to not find the home partition and so on. The result is an unbootable system. Which sucks big time.
Comment 1 Till Maas 2008-09-26 15:14:25 EDT
Parsing of /etc/crypttab is afaik done by initscripts, there I reassign this bug.
Comment 2 Bill Nottingham 2008-09-26 16:10:21 EDT
What does your crypttab look like? Are you using plymouth?
Comment 3 Lennart Poettering 2008-09-26 18:12:31 EDT
This is my crypttab:

fedora-home-crypto /dev/fedora/home none luks,tries=5

Yes, plymouth was installed automatically for me but failed tragically too, see bug 464216.
Comment 4 Bill Nottingham 2008-09-29 16:30:56 EDT
If you're not booting with plymouth, it will fail. This is because (AFAIK) plymouth isn't optional. Have we enforced that completely in the initrd now?
Comment 5 Ray Strode [halfline] 2008-09-29 17:40:00 EDT
his problem isn't initrd time, it's post / mounted, pre /usr mounted time

plymouth ask-for-password --command "cryptsetup luksOpen blah blah" is failing because /usr/lib/libply.so isn't available yet.

We could just mark this one a dupe of 464216.  Really I thought we stopped supporting late /usr a couple of releases ago though.

*** This bug has been marked as a duplicate of bug 464216 ***

Note You need to log in before you can comment on or make changes to this bug.