Bug 464265 - No Log out function in the oVirt system
No Log out function in the oVirt system
Status: CLOSED NOTABUG
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Hugh Brock
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 23:22 EDT by Vivian Bian
Modified: 2010-03-16 13:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 13:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivian Bian 2008-09-26 23:22:19 EDT
Description of problem:
After we login with the ovirtadmin account ,we can’t logout it any more.

Version-Release number of selected component (if applicable):

oVirt 0.93
How reproducible:
Always

Steps to Reproduce:
1.start the ovirt-appliance in the terminal
   #virsh start ovirt-appliance
   #virt-viewer ovirt-appliance
2.login the ovirt Administration User Interface
   1)open  the web browser and type the 192.168.50.2/ovirt in the address pane.
   2)input the UserName and  Password (ovirtadmin   ovirt)
  
Since then,we can’t log out the account of ovirtadmin
Actual results:

we can’t log out any user logged in the ovirt system
Expected results:
we can log out any user logged in the ovirt system as we need

Additional info:
Comment 1 Susan Burgess 2008-10-06 01:00:32 EDT
not a doc bug. However, may bhave doc implications, so I've put myself on the CC list.
Comment 2 Hugh Brock 2008-10-17 13:39:21 EDT
user sign-in/sign-out in oVirt is intentionally delegated to a separate single-sign-on system by default. The http username/password authentication is just a fallback for the case when a proper single-sign-on system (i.e. kerberos or a certificate management system) is not in place. Therefore I don't think we want to provide a logout button since in most cases it would make no sense to have one. To work around this for the username/password case, just close and restart your browser and log in as a different user.

Note You need to log in before you can comment on or make changes to this bug.