Bug 464270 - INFO: task crond:1789 blocked for more than 120 seconds. --- Then system froze up
INFO: task crond:1789 blocked for more than 120 seconds. --- Then system froz...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
9
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 01:03 EDT by Cranky
Modified: 2008-10-14 14:05 EDT (History)
5 users (show)

See Also:
Fixed In Version: 2.6.26.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 14:05:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs Before Crash (15.09 KB, text/plain)
2008-09-27 10:03 EDT, Cranky
no flags Details

  None (edit)
Description Cranky 2008-09-27 01:03:01 EDT
Description of problem:
Logs show issue with crond task, eventually system hangs. Last bit of output from /var/log/messages is attached (var-log-messages.txt)showing err's before system halted.

Version-Release number of selected component (if applicable):
RPM Group    : System Environment/Base
Source       : cronie-1.0-7.fc9.src.rpm
Yum Group    : Base System/Base
 -> Type     : Mandatory
Build Time   : Wed Jun  4 05:08:07 2008
Install Time : Thu Sep 25 11:05:44 2008
License      : MIT and BSD

Kernel Ver - Linux fedora64 2.6.26.3-29.fc9.x86_64 #1 SMP Wed Sep 3 03:16:37 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

Processor - AMD Athlon 64 3200+ 2Ghz
Memory - 2GB RAM


How reproducible:
I dont know how to, it just happened....

Steps to Reproduce:
1.N/A
2.N/A
3.N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
N/A
Comment 1 Cranky 2008-09-27 10:03:10 EDT
Created attachment 317866 [details]
Logs Before Crash

Logs Before Crash
Comment 2 Marcela Mašláňová 2008-09-29 08:14:21 EDT
You've probably found kernel bug.

http://bugzilla.kernel.org/show_bug.cgi?id=10582
Comment 3 Chuck Ebbert 2008-09-30 00:03:57 EDT
This might be fixed in 2.6.26.5-45, which got a lot of timer and clock fixes.
Comment 4 Cranky 2008-09-30 01:11:25 EDT
(In reply to comment #3)
> This might be fixed in 2.6.26.5-45, which got a lot of timer and clock fixes.

I noticed that 2.6.26.5-45 falls under the "updates-testing" repository. Should I be installing stuff from there, or will my system become unstable from installing things from "updates-testing" and "updates-testing-newkey"? Will it eventually be available in the main "updates" repository?
Comment 5 Chuck Ebbert 2008-10-04 01:54:51 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > This might be fixed in 2.6.26.5-45, which got a lot of timer and clock fixes.
> 
> I noticed that 2.6.26.5-45 falls under the "updates-testing" repository. Should
> I be installing stuff from there, or will my system become unstable from
> installing things from "updates-testing" and "updates-testing-newkey"? Will it
> eventually be available in the main "updates" repository?

It's released.
Comment 6 Chuck Ebbert 2008-10-09 08:40:04 EDT
Did 2.6.26.5-45 fix the problem?
Comment 7 Cranky 2008-10-09 20:56:48 EDT
I updated to 2.6.26.5-45 when the system advised that the update was available. Since the original occurrence the "blocked for more than 120 seconds" the system has not shown this behaviour in the logs especially after the upgrade to 2.6.26.5-45 kernel.

Note You need to log in before you can comment on or make changes to this bug.