Bug 464309 - MD5 sum mismatches when trying to install packaes with synaptic
MD5 sum mismatches when trying to install packaes with synaptic
Status: CLOSED DUPLICATE of bug 449168
Product: Fedora
Classification: Fedora
Component: synaptic (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 13:44 EDT by Nigel Henry
Modified: 2009-07-31 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-01 08:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Henry 2008-09-27 13:44:03 EDT
Description of 
Before the Fedora servers were compromised Synaptic was working just fine for installing packages. I have history in synaptic to verify that.

when the servers came back online using the newkwy repos, I initially did a yum update, which installed the newkeys, and then followed by another yum update, which fetched all the outstanding updates. Apt-get update was not working at this time.

A couple of days later a yum update installed "fedora-package-config-apt", which has sort of got apt-get update/apt-get dist-upgrade working now, but still with some problems.

Ok. Apt is working more or less, but Synaptic is having problems installing packages. As an example I select Qsynth to install, and follow the usual procedure. Qsynth is downloaded ok (verified by it now existing in /var/cache/apt/archives), but fails to install as below.

One error shows:
APT system reports:
W: Some errors occured while running transaction.

I close that one, and the error window beneath shows as below:

The window header says "Package Manager output"
And the content:
While Installing package qsynth-0.3.3-1.fc9:

error: unpacking of archive failed on file /usr/bin/qsynth;48de6b19:
cpio: MD5 sum mismatch.

W: Some errors occurred while running transaction.

Now Qsynth has already been downloaded by synaptic, so I close synaptic, and do an apt-get install qsynth, and it installs with no problems.

I've already asked about this problem on the Fedora list, but from the responses it seems that I'm the only only one using apt, and synaptic.







Version-Release number of selected component (if applicable):
0.57.2-16.fc9


How reproducible:
Always, on all packages, whether single packages, or packages with deps


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Kofler 2008-11-01 08:37:09 EDT

*** This bug has been marked as a duplicate of bug 449168 ***

Note You need to log in before you can comment on or make changes to this bug.