Bug 46431 - unresolved symbols in libbitmap.a causes Sig11
unresolved symbols in libbitmap.a causes Sig11
Status: CLOSED DUPLICATE of bug 44954
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-28 10:18 EDT by Peter H.S.
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-28 10:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree error-log when it crashed. (4.01 KB, text/plain)
2001-06-28 10:20 EDT, Peter H.S.
no flags Details

  None (edit)
Description Peter H.S. 2001-06-28 10:18:27 EDT
Description of Problem:
XFree86-4.1.0-0.5.9.i386.rpm seems to contain unresolved symbols in 
/usr/X11R6/lib/modules/fonts/libbitmap.a .
After upgrading to this version of XFree, 'startx' results in a Sig11 
crash and core dump. (logfile attached)


How Reproducible:
Every time

Steps to Reproduce:
1. Install all apropriate XFree and Mesa rpm packages from Raw Hide with 
a 'rpm -Fvh *.rpm' from the command line

2. Issue a 'startx' to start the X-server

Actual Results:
Crash with a Signal 11, core dump, and complaints from XFree about 
unresolved symbols.

Expected Results:
The X-server should start.

Additional Information:
I use a MACH64, ATI RageIIC graphic adaptor. But even though Sigal 11 
usually is associated with faulty hardware, I think that this is not the 
case here. The previous Raw Hide XFree versions worked without problems.
Likewise, when doing a roll back to XFree 4.0.3, no problems occur.

The package containing the unresolved symbols is:
XFree86-4.1.0-0.5.9.i386.rpm

When upgrading I did issue 'rpm -e (problem package like V4L*)' until a 
'rpm -Fvh XFree*.rpm --test' yielded no errors.
Several other installs ('rpm -Uvh 'rpm -ivh' --force) made no difference.

When manually deleting the offending 
"/usr/X11R6/lib/modules/fonts/libbitmap.a" XFree complained about that 
the rest of the modules in this dir, had unresolved symbols.
Comment 1 Peter H.S. 2001-06-28 10:20:35 EDT
Created attachment 22066 [details]
XFree error-log when it crashed.
Comment 2 Mike A. Harris 2001-07-02 21:12:16 EDT

*** This bug has been marked as a duplicate of 44954 ***

Note You need to log in before you can comment on or make changes to this bug.