Bug 464316 - Gnome-session unnecessarily listens on wildcard addreses.
Gnome-session unnecessarily listens on wildcard addreses.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-27 16:07 EDT by Ralph Loader
Modified: 2008-09-28 15:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-28 15:11:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2008-09-27 16:07:14 EDT
On a fresh install of rawhide [x86-64], and logging into the gnome desk top I get:

$ ss -ap
...
LISTEN     0      128                     *:60650                    *:*        users:(("gnome-session",6500,11))
LISTEN     0      128                    :::58934                   :::*        users:(("gnome-session",6500,10))
...

There is no reason for gnome-session to be attempting to expose itself to the outside world.

It should either be binding to localhost or [even better] using unix sockets [of which it has plenty open].
Comment 1 Matthias Clasen 2008-09-28 15:11:43 EDT
This was caused by a missing BuildRequires. 
Fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.