Bug 464317 - Yum live upgrade 8 -> 9 dependency hell.
Yum live upgrade 8 -> 9 dependency hell.
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-09-27 17:45 EDT by Michael H. Warfield
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-07 13:45:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael H. Warfield 2008-09-27 17:45:27 EDT

Yes, I know this is not a "supported" path but it's the only viable path with remote servers systems and serial consoles.  Tried the "preupgrade" option once.  It blows goats and I won't even waste my time on THAT again...  Realize that some of us don't have the option of having hands on a keyboard on a console to perform upgrades from a CD or facsimile.  Anaconda is not an option and the blind fire and forget anaconda-ks.cfg method is way too risky without some way to make it play nice with a serial console.

The wiki page on live yum upgrades says to report dependency problems in bugzilla.  Here you go.  You've got a good one thanks to that key change over and a little bit of version problems.

Description of problem:

Live upgrade from Fedora 8 to Fedora 9 currently has some serious gotcha's.

1) After installing the "fedora-release" packages via rpm, the next step must be "yum upgrade fedora-release" in order to pick up the transitional package for the key change.  That's reasonable and merely needs to be added to the 9->8 section of the yum upgrade wiki page.

2) Several F9 packages have the same revision as their F8 counterparts but have different openssl dependencies.  Consequently, yum is not going to update them even though it does want to update openssl.  This results in a dependency failure because libssl and libcrypto are re-reving and some of the packages which depend on .6 are not.  Only workaround I have found is to download and force install (not update) the latest openssl so that both .6 and .7 are on the system.  The only conflicts seem to be the shared info files and the openssl command itself (which I don't care about and would prefer the newer version overwrite the older one anyways).

3) I also ran into some openldap dependencies similar to the openssl dependencies but they seemed to clear up once I did the update to fedora-release to deal with the key rollover issue.  Not sure if there's a problem lurking in the bushes on that one or not.

Version-Release number of selected component (if applicable):


All related packages depending on the above two.

How reproducible:

Every system I've tried to upgrade today (~6 not counting virtual systems)
Comment 1 seth vidal 2008-11-07 13:45:07 EST
The root of this bug is that openssl in f8-updates was a higher version at the point you updated than what was in f9-ga. So it couldn't get the updates in place.

This particular problem has been fixed. I'm going to close this b/c ultimately this is just a packaging bug.

thanks for the report, I'm sorry it went unresponded to for so long

Note You need to log in before you can comment on or make changes to this bug.